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Chapter-1 
Introduction to Computer Fundamentals 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Understanding  the basic concepts of IT 
An Information Technology (IT) system concerns the processing , storage and/or transfer of 
information. Information can take many different forms such as words , numbers , pictures, 
sounds or video . An IT System can consist of computers, the telecommunications network and 
other programmable electronic devices. 

 
What is a Computer ? 
A programmable machine. The two principal characteristics of a computer 
are: It responds to a specific set of instructions in a well-defined manner. 
It can execute a prerecorded list of instructions (a program) 

 
 
Characteristics  of Computer 
1 Speed : Computer provides speed incredibly faster than what man can possibly record or 
calculate normally . 
2 Storage : One of man's failings is perhaps his inability to remember and store large volumes 
of information is his brain . In computer the terminology in regard to storages capacity applies to 
both primary and secondary storages. It is normally measured in terms of Nibble , Byte, Kilobyte[ 
1KB] Mega Byte [MB], Giga Byte [GB] AND Tera Byte [TB]. Example : Floppy disks, Magnetic 
disks & Tapes etc. 
3 Accuracy And Reliability : Computer's are quite reliable in its calculation. The accuracy of 
operation of computer is always 100%. Computer is only a machine and does not make errors on 
its own. It is thus reliable . 
4 Automatic : The computer is quite capable of functioning automatically , once the process 
has been initiated. 
5 Diligence / Endurance: The computer is capable of operating at exactly the same level of 
speed and accuracy even if it has to carry out the most voluminous and complex operations for a 
long period of time. 
6 Versatility: The wide use of computer in so many areas such as scientific, commercial 
applications, Educational industrial areas in day –to –day life there is an ample evidence of its 
versatility. 
Application of Computer 
Computers have their application or utility everywhere. We find their applications in almost 
every sphere of life–particularly. 
In Tourism: Hotels use computers to speed up billing and checkout the availability of rooms. 
So is the case with railways and airline reservations for booking tickets. 

1



In Banks: Banks also have started using computers extensively. 
In Industry: Computers are finding their greatest use in factories and industries of all kinds. 
In Education: Computers have proved to be excellent teachers. They can possess the 
knowledge given to them by the experts and teach you with all the patience in the world. You may 
like to repeat a lesson hundred times, go ahead, you may get tired but the computer will keep on 
teaching you. 
In Entertainment: Computers are also great entertainers. Many computer games are available 
which are like the traditional games like chess, football, cricket, etc. 
Concept of Hardware and Software 
Hardware: 
Personal computer hardware are component devices which are typically installed into or 
peripheral to a computer case to create a personal computer. These are devices that can be touch. 
Software: 
Computer software is a collection of computer programs and related data that provide the 
instructions for telling a computer what to do and how to do it. 
Computer Memory 

 

Computer Memory is internal storage areas in the computer used 
to either temporarily or permanently store data or instructions to 
be processed. There are four basic types of computer memory: 
Cache Memory, RAM, Virtual Memory and Hard Drives. With 
modern CPU's running at speeds of 1 gigahertz or higher, it is hard 
for computer memory to keep up with the extreme amount of data 
being processed. Computer engineers fixed the problem by 
"tiering" memory. 

 

Types of Computer Memory 
 

1. Computer RAM: Computer RAM is the best known form of memory your computer uses. 
Every file or application opened is placed in RAM. Any information the computer needs or uses 
becomes part of a continuous cycle where the CPU requests data from RAM, processes it and then 
writes new data back to RAM. This can happen millions of times a second. However, this is usually 
just for temporary file storage, so unless the data is saved somewhere, it is deleted when the files 
or applications are closed. 

2. Hard Drive: A Hard Drive is a form of computer memory that allows you to permanently store 
data. This is where all of your permanent files and programs are stored. On computers running 
with Microsoft windows the Hard Drive is often called C-Drive. The size of a Hard Drive is typically 
measured in gigabytes. 
2. Hard Drive: A Hard Drive is a form of computer memory that allows you to permanently store 
data. This is where all of your permanent files and programs are stored. On computers running 
with Microsoft windows the Hard Drive is often called C-Drive. The size of a Hard Drive is typically 
measured in gigabytes. 
3. Virtual Memory: Virtual memory typically comes into place when applications are too large 
for the RAM to handle. The operating System uses the hard drive to temporarily store information 
and take it back when needed. This is normally a lot slower than actual RAM and can possibly 
degrade performance if used to heavily. 
4. Cache Memory: Cache memory is extremely fast memory that is built into a computer's 
central processing unit (CPU), or located next to it on a separate chip. The CPU uses cache 
memory to store instructions that are repeatedly required to run programs, improving overall 
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system speed. The advantage of cache memory is that the CPU does not have to use the 

motherboard's system bus for data transfer. Whenever data must be passed through the system 

bus, the data transfer speed slows to the motherboard's capability. The CPU can process data 

much faster by avoiding the bottleneck created by the system bus. 

Primary and Secondary Memory 
 

Modern electronic computers generally possess several distinct types of memory, each of which 

"holds" or stores information for subsequent use. The vast majority of computer memory can be 

placed into one of two categories: primary memory and secondary memory. 

Primary memory, often called main memory, constitutes that device, or group of devices, that 

holds instructions and data for rapid and direct access by the computer's central processing 
unit (CPU). Primary memory is synonymous with random-access memory (RAM). As a 

computer performs its calculations, it is continuously reading and writing information to and from 

RAM. For instance, instructions and data are retrieved from RAM for processing by the CPU, and 

the results are returned to RAM. Modern RAM is made of semiconductor circuitry, which 

replaced the magnetic core memory widely used in computers in the 1960s. RAM is a volatile form 

of information storage, meaning that when electrical power is terminated any data that it contains 

is lost. There are other semiconductor memory devices accessed by the CPU that are generally 

considered as being distinct from primary memory (i.e., different from RAM). These memory 

units include cache memory, read-only memory (ROM), and Programmable Read Only 

Memory (PROM). 

Secondary memory, also called auxiliary memory or mass storage, consists of devices not directly 

accessible by the CPU. Hard drives, floppy disks, tapes, and optical disks are widely used for 

secondary storage. The input and output of these devices is much slower than for the 

semiconductor devices that provide the computer's primary memory. Although access times (i.e., 

the time to read or write information) are slow as compared to that of primary memory, 

secondary memory devices have important features that are unmatched by primary memory. 

First, most secondary storage devices are capable of containing much more information than is 

feasible for primary memory (hence the use of the term "mass storage" as a synonym for 

secondary memory). A second, and essential, feature of secondary memory is that it is non- 

volatile. This means that data is stored with or without electrical power being supplied to the 

device, as opposed to RAM, which can retain its data only so long as electrical power is present. 
 

Like primary memory, many secondary memory devices are capable of storing information, as 

well as retrieving it. Magnetic technology devices (such as hard drives, floppy disks, and tape) 

have this read-write capability, as do magneto-optical drives. However, some mass storage 

devices can only read data, as in the case of CD-ROM (Compact Disk-Read Only Memory) drives. 

CD-ROMs utilize optical technology; however, newer optical technologies, such as CD-RW 

(compact disk-rewriteable), can both read and write information like magnetic storage devices. 

ROM (Read Only Memory): This is a special type of memory which contains all the information 

the computer needs to switch itself on, check that all its systems are working 
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and to tell the PC what things are plugged into it. It cannot be changed or overwritten by you, and 
stays the same even when the PC is switched off. An example of ROM on a PC is the BIOS software 
(Basic Input Output System) that enables the computer to start up and allows components to 
communicate with each other. 

RAM (Random Access Memory): Random access memory is used in a PC to temporarily store 

data when you are using applications. RAM is also used to store program instructions and feed 

information to the CPU to process. RAM is not permanent, when you switch off the PC (or shut 

down), the contents of RAM are lost or emptied. There are two main uses of RAM in a computer 

system. These are main memory and cache. 
BASIC UNITS OF MEMORY 

 
 
 

UNITS MEANING 
 

Nibble 
Byte 
1 kilo Bytes [1KB ] 
1 Mega Byte [1MB] 
1 Giga Byte [1MB] 
1 Tera Byte [1TB] 

 

4 bits 
8  bits 
210 = 1024 bytes 
220 = 1024 KB 
230 =1024 MB 
240=1024 GB 

INPUT AND OUTPUT DEVICES 
 

The computer will be of no use unless it is able to communicate with the outside world. 

Input/output devices are required for users to communicate with the computer. Input devices 

bring information INTO the computer and output devices bring information OUT of a computer 

system. These input/output devices are also known as peripherals since they surround the CPU 

and memory of a computer system. Some Commonly used input/ output devices are listed in 

table below. 
 

Input Devices Output Devices 
 

Keyboard 
 

Monitor 
Mouse LCD 
Joystick Printer 
Scanner Plotter 

Light Pen 
Touch Screen 

Input Devices 
 

(a) Keyboard 
It is a text base input device that allows the user to input alphabets, 
numbers and other characters. It consists of a set of keys mounted on a 
board. 
Alphanumeric Keypad 
It consists of keys for English alphabets, 0 to 9 numbers, and special characters like + − / * ( ) etc. 
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Function Keys:- There are twelve function keys labeled F1, F2, F3… F12. The functions assigned 
to these keys differ from one software package to another. These keys are also user 
programmable keys. 
Special-function Keys:- These keys have special functions assigned to them and can be used 
only for those specific purposes. Functions of some of the important keys are defined below. 
Enter:- It is similar to the 'return' key of the typewriter and is used to execute a command or 
program. 
Spacebar:-It is used to enter a space at the current cursor location. 

 

Backspace:-This key is used to move the cursor one position to the left and also delete the 
character in that position. 
Delete:-It is used to delete the character at the cursor position. 

 

Insert:-Insert key is used t toggle between insert and overwrite mode during data entry. 
 

Shift:- This key is used to type capital letters when pressed along with an alphabet key. It can be 
used to type the special characters located on the upper-side of a key that has two characters 
defined on the same key. 
Caps Lock:- Cap Lock is used to toggle between the capital lock features. When 'on', it locks the 
alphanumeric keypad for capital letters input only. 
Tab:- Tab is used to move the cursor to the next tab position defined in the document. Also, it is 
used to insert indentation into a document. 
Ctrl:- Control key is used in conjunction with other keys to provide additional functionality on the 
keyboard. 
Alt:-Also like the control key, Alt key is always used in combination with other keys to perform 
specific tasks. 
Esc:- This key is usually used to negate a command. Also used to cancel or abort executing 
programs. 
Numeric Keypad:- Numeric keypad is located on the right side of the keyboard and consists of 
keys having numbers (0 to 9) and mathematical operators (+ − * /) defined on them. This 
keypad is provided to support quick entry for numeric data. 
Cursor Movement Keys:- These are arrow keys and are used to move the cursor in the direction 
indicated by the arrow (up, down, left, right). 
(b) Mouse 
The mouse is a small device used to point to a particular place on the screen 
and select in order to 
perform one or more actions. It can be used to select menu commands, size 
windows, start 
programs etc. The most conventional kind of mouse has two buttons on top: 
the left one being 
used most frequently. 
Mouse Actions 
Left Click : Used to select an item. 
Double Click : Used to start a program or open a file. 
Right Click : Usually used to display a set of commands. 
Drag and Drop : It allows you to select and move an item from one location to another. To 
achieve this place the cursor over an item on the screen, click the left mouse button and while 
holding the button down move the cursor to where you want to place the item, and then release it. 
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(c) Joystick 
The joystick is a vertical stick which moves the graphic cursor in a direction the 
stick is moved. It typically has a button on top that is used to select the option 
pointed by the cursor. Joystick is used as an input device primarily used with 
video games, training simulators and controlling robots. 
(d) Scanner 

 

Scanner is an input device used for direct data entry from the source 

document into the computer system. It converts the document image into 

digital form so that it can be fed into the computer. Capturing information like 

this reduces the possibility of errors typically experienced during large data 

entry. Hand-held scanners are commonly seen in big stores to scan codes and price information 

for each of the items. 

(e) Bar codes 
 

A bar code is a set of lines of different thicknesses that represent a number. Bar 

Code Readers are used to input data from bar codes. Most products in shops 

have bar codes on them. Bar code readers work by shining a beam of light on 

the lines that make up the bar code and detecting the amount of light that is 

reflected back 

(f) Light Pen 
 

It is a pen shaped device used to select objects on a display screen. It is quite like the mouse (in its 

functionality) but uses a light pen to move the pointer and select any object on the screen by 

pointing to the object. Users of Computer Aided Design (CAD) applications commonly use the 

light pens to directly draw on screen. 

(g) Touch Screen 
 

It allows the user to operate/make selections by simply touching the display screen. Common 

examples of touch screen include information kiosks, and bank ATMs. 

(h) Digital camera 
 

A digital camera can store many more pictures than an ordinary camera. Pictures taken using a 

digital camera are stored inside its memory and can be transferred to a computer by connecting 

the camera to it. A digital camera takes pictures by converting the light passing through the lens 

at the front into a digital image. 

Output Devices 
 

(a) Monitor 
 

Monitor is an output device that resembles the television screen and uses a 

Cathode Ray Tube (CRT) to display information. The monitor is associated with a 

keyboard for manual input of characters and displays the information as it is 

keyed in. It also displays the program or application output. Like the television, 

monitors are also available in different sizes. 
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(b) Liquid Crystal Display (LCD):- LCD was introduced in the 1970s and is now applied to 
display terminals also. Its advantages like low energy consumption, smaller and lighter have 
paved its way for usage in portable computers (laptops). 

 

Printer:- Printers are used to produce paper (commonly known as hard copy) output. They 
can be classified as Impact or Non-impact printers. Impact printers use the typewriting printing 
mechanism wherein a hammer strikes the paper through a ribbon in order to produce output. 
Dot-matrix and Character printers fall under this category. Non-impact printers do not touch the 
paper while printing. They use chemical, heat or electrical signals to draw the symbols on paper. 
Inkjet, DeskJet, Laser, Thermal printers fall under this category of printers. 

 

Classification of Software 
Software is the interface between the user and the hardware. Users mainly interact with the 
computer through the software. Software is an important basis for computer system design. To 
facilitate the users, in order to make the computer system has a higher overall utility, in the 
design of computer systems must take into account the global combination of software and 
hardware, and user requirements and software requirements. 
System Software 

 

System software is to provide the most basic function of computer, and it can be divided into the 
operating system and support software, of which operating system is the basic operating system 
software. System software is responsible for managing the systems. System software enables 
computer users and other software take the computer as a whole without the need to take into 
account how each of the underlying hardware works. 

Application Software 
 

Application is developed for a certain purpose. It can be a specific program, such as an image 
browser. It can also be a set of functions that can be closely linked, you can collaborate with each 
other a collection of programs, such as Microsoft's Office software. It can also be a separate 
program consisting of many large software systems, such as database management systems. 

 

Operating Systems and its functions 
 

An operating system is the most important software that runs on a computer. It manages the 
computer's memory, processes, and all of its software and hardware. It also allows you to 
communicate with the computer without knowing how to speak the computer's "language." 
Without an operating system, a computer is useless. 

 

COMPUTER LANGUAGES 
 

Machine Language:-A set of instructions for a specific central processing unit, designed to be 
usable by a computer without being translated. The set of instructions, encoded as strings of 
binary bits, interpreted directly by a computer's central processing unit. Each different type of 
central processing unit has its own machine language. For a given machine language, each 
unique combination of 1's and 0's in an instruction has a unique interpretation, including such 
operations as arithmetical operations, incrementing a counter, saving data to memory, testing if 
data has a certain value, and so on. Computer programs are rarely written directly in machine 
language; instead, higher-level programming languages are used. 

 

Assembly Language:- This language uses ' mnemonic codes ' or symbols in place of 0'S AND 1'S 

.Instead of remembering the exact memory the exact memory location where data and 
instruction are stored , symbolic memory addresses are used for data .Translator programs 
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known as Assemblers were developed to convert the assembly language program into machine 

language . Assembly language is also machine – dependent and programming in this language is 

also very time consuming. Thus, it is also programming as a low level language. 

High Level Language 
 

High level language is quite similar to English language. Basic, C, C++, java etc. are some of the 

very popular high level languages. High Level languages programs needs to be translated into 

machines language by using .Translator Programs .There are two types of translator programs. 

ROLE OF ASSEMBLER AND COMPILER 
 

ASSEMBLER 
 

An assembler is used to translate assembly language statements into the target computer's 

machine code. 

COMPILER 
 

It is a translator program to convert a high level language program into machine language. It 

translates whole program at once, i.e., it generates the object code for the program along with a 
list of errors, if any .The execution is very fast. 
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Chapter-2 
Open Office Writer 

 
 
 
Open Office.org is reasonably intuitive but is sufficiently different to other suites that a period of 
familiarization required before use is fluid and effective. This chapter starts with a general 
explanation of the most common control features in Open Office.org, such as toolbars, floating 
toolbars and dockable windows. This is followed by information on functions that can be used in 
most of the program modules of Open Office.org. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Creating & Editing Text 
A text document is displayed and edited in the Writer window. Spreadsheet, presentations or 
drawings are displayed in very similar windows, except the menus and icons change 
automatically depending on the context. 
Entering and Formatting Text 
There is no prescribed sequence in which to work. One can enter text and, let us say, underline it 
or italicize it while typing or choose to do this later. Users can also decide whether or not to split a 
section of text into two columns immediately or to delay the action. Text never has to be deleted 
and retyped simply because formatting needs changing. Basically, to edit text, first select it and 
then choose the relevant command, such as the one to format the text in italics. There are several 
ways of selecting text, for example, using the arrow keys whilst holding down the Shift key, or 
with the mouse whilst keeping the mouse button depressed. Often there are different ways of 
choosing a command, for example, with a menu command, with a toolbar icon or with shortcut 
keys. 
Entering New Text 
To enter new text: 
1. Open an existing text document or create a new one. 

 

2. Enter text using the keyboard. When special characters, such as the copyright symbol or 

accented characters that are not available on the keyboard are to be entered, select Insert > 
Special Character and chose what is needed from the table. 

3. Press Enter to begin a new paragraph. 
 

Line breaks 
 

Users never need to worry about line breaks as the software inserts these automatically. Only 
press Enter at the point to start a new paragraph. 
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Inserting Text 
 

1. Open an existing document. 
 

2. Place the cursor at the point where text is to be added using either the mouse or the arrow keys, 
and enter the new text. 
Insert mode is enabled by default, thus any text, following the insertion point, is shifted as new 
text is entered. To overwrite the existing text at this point, select Overwrite mode by clicking the 
INSRT field in the status bar as shown below. 

 
 
 
Entering Text Anywhere on a Page 
Writer enables one to enter text at any position within the type area in the text document. This is 
the direct cursor function: 
Click the Direct Cursor on/off icon on the main toolbar. Clicking the icon turns the direct cursor 
on and off. When the icon appears pressed, the direct cursor is enabled. Click on a free space in 
the text document. The shape of the mouse pointer shows how the text that is entered will be 
aligned 

 
 
 
 
 
Enter the text. OpenOffice.org automatically inserts the requisite number of blank lines, tabs and 
spaces. 
Selecting and Deleting Text 
Some basic steps to start: 
Deleting characters 
To delete one character to the left of the cursor., press Backspace (above the Enter key). 
To delete one character to the right of the cursor, press the Delete key (may be labeled Del). 
Deleting text 
Selecting text to delete with the mouse 
1. Left-click to set the cursor on the first character to be deleted. 
2. Keeping the mouse button depressed, drag the pointer to the last character to be deleted. The 
characters will be highlighted. 
3. Release the mouse button. 
4. Press the Delete key to delete the selected text. 
Selecting text to delete with the keyboard 
1. Use the arrow keys to go to the first character to be deleted. 
2. Hold down the Shift key. 
3. Using, the arrow keys, move the cursor to just after the last character to be deleted. 
4. Release the Shift key. The text is highlighted. 
5. Press the Delete key to delete the selected text. 
Inserting Special Characters 
This is how to insert special characters (such as check marks, boxes, telephone symbols etc.) in 
text: 
Select Insert > Special Characters. view the selection of characters available. 
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In the large selection field select the desired character or more than one by clicking with the 
mouse or by navigating by keyboard in succession. The characters are displayed at the bottom of 
the dialogue box. Upon closing the dialogue with OK, all displayed characters in the selected font 
are inserted in the current document at the cursor. 
If a special character is required in any text input field (such as in the URL field of the function bar 
or in the input fields in the Find & Replace dialogue), press Shift + Ctrl + S to pop up the Special 
Characters dialogue. 

 

Emphasizing Text 
There are many ways of emphasizing text in a special way. Here are some of them: 

Use the icons in the Object bar for regular Formatting needs. For example, change the text to 
bold or to another font style, change the text color and background, or center the text. 

Whole paragraph can be emphasized using borders. Place the cursor in the paragraph that is to 
be emphasized, right-click to its context menu and select Paragraph, then click on, for example, 
the Borders tab. At this point, a border may be selected to frame the paragraph, and also with 
shadow shading, if desired. If necessary the distance between the border and the paragraph text 
can be adjusted under Spacing to contents. 

Using a Text Frame provides the following possibilities: 
a) Text can receive a border 
b) Text can be placed outside of the text margin on the side of the page. 
c) Text frames can be linked when text should flow from one frame to another. 

Choose Format > Paragraph > Background to apply a background color to the paragraph. 
Use the Draw Text “function: Open the Draw function toolbar (on the main toolbar), select 

the Text icon, drag open a frame and enter the text. This text can be positioned as desired, which 
includes rotating at various angles, or curving and slanting the text with the help of Format > 
Font Work. 
Changing the color of Text 
Click the Font color icon in Writer and other modules, and keep the mouse button pressed to 
obtain a floating toolbar from which to choose a color from the range of colors. Note the color 
shown in the bar at the bottom. When using a short-click with no text selected, the mouse pointer 
changes its appearance to a watering can. Drag this watering can symbol while keeping the 
mouse key pressed, across the target text area. This text area now takes on the selected color. 
The function remains active for as long as the icon is active (looks depressed), or until simply 
clicking without dragging, or until the (Esc) key is pressed. 
Working with tables 
Inserting a new table 

 

To insert a new table, position the cursor where 
you want the table to appear, then use any of the 
following methods to open the Insert Table dialog 
box: 

From the main menu, select Table > Insert > Table. 

Press Control+F12. 

From the Standard toolbar, click the Table icon  
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Inserting rows and columns 
 

1. Place the cursor in the row or column where you want to add new rows or columns and right- 

click. 

2. On the pop-up menu, select Row > Insert or Column > Insert. This will display a 
 

dialog box where you can select the number of rows or columns to add, and whether they appear 

before or after the selected one. 

3. Set Amount to the number of rows or columns to insert, and Position to Before or After. 
 

4. Click OK to close the dialog box. 
 

Deleting Rows Or Columns 
1. Click in one of the empty rows you just added. Click Table > Delete, > Rows or click 
the Delete Row   icon on the Table Toolbar.(The row is deleted.) 
2. Click in the empty column you just added. Click Table > Delete > Columns or  click the 
Delete Column  icon on the Table Toolbar. 

 
Resizing rows and columns 

 

1. You can adjust the height of rows and the width of columns in a table in several  ways. 
 

2. Move the mouse next to the edge of the cell and when a double-headed arrow appears, 

click and hold the left mouse button, drag the border to the desired position, and release 

the mouse button. 

3. On the horizontal ruler, column dividers are marked by a pair of thin gray lines; the vertical 

ruler indicates row dividers in the same way. You can resize a row or column by holding the 

mouse button down on the appropriate divider and dragging it to the desired location. 

4. Use the keyboard as described below. 
 

5. Selecting Table >Auto fit from the main menu also offers some resizing options: 
 

6. The Optimal Column Width or Optimal Row Height options make the columns or  rows as 

narrow as possible while still fitting their contents. 

7. Columns and rows can be distributed evenly to quickly bring them back to all being the 

same width or height. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
For greater control over the width of each column, use the Columns page of the Table Format 
dialog box. Right-click on the table and select Table from the pop-up menu or select Table > 
Table 

 

Properties from the menu bar. On the Table Format dialog box, select the Columns tab. 
 

MERGING AND SPLITTING CELLS 
To merge a group of cells into one cell: 
1. Select the cells to merge. 
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2. Right-click and select Cell > Merge on the pop-up menu or select Table > Merge Cells from the 
menu bar. To split a cell into multiple cells: 
3. Position the cursor inside the cell. 

 

4. Right-click and select Cell > Split on the pop-up menu or select Table > Split Cells from the 
menu bar. 
5. Select how to split the cell. A cell can be split either horizontally (create more rows or 
vertically (create more columns), and you can specify the total number of cells to create. 
DELETE A TABLE 
1. Click in the table you want to delete. 
2. Click Table > Delete > Table.;The table is deleted. 

3. To undo Delete Table, click on the Undo    , icon on the Standard  
Toolbar. 

Mail Merge 
The Mail Merge feature includes the following 

1. Address Book: An Address Book is created that can be used in very many different ways. 
2. Form Letters: One document is created that is sent by regular mail to multiple 
recipients. Each individual who receives a letter will have their name and  address printed within 
their letter. 
3. Labels: Address Labels are created that are placed on envelopes. Return Labels can be 
created and can have various images such as for a company or the Holiday Season. 
4. Envelopes: Envelopes are printed with the recipient's name and address. The senders name 
and address may also be printed on the envelope. 
Print An Envelope 
1. Have an envelope in your printer feed tray. Be sure that your printer is expecting the correct 
size of the envelope. 
2. Click File > Print. 
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Chapter-3 
Open Office Impress 

 
 
 
The Open Office suite of tools-Writer, Calc, Impress, and Draw- offers comparable capabilities 
to Microsoft Office's suite of tools-Word, Excel, and PowerPoint. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
After launching OpenOffice.org. An Auto Pilot Presentation window appears. Empty 
presentation creates a presentation from scratch. 
Creating a new presentation 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The Effect option creates transitions between all the slides in the presentation. Select No 
Effect for no transition effect. Transitions can be added and changed later. Click "Create" to 
end the Autopilot. 
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Type in a title for the slide in the area marked Name.  Click a thumbnail slide from a "Select an 
Autolayout" section to select that layout. Click OK. 

 

Inserting Slides 
 
 
 
 
 
 
 
 
 
 
To add a slide to the new presentation, go to the Insert menu and select "Slide...” 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Insert a title for the slide in the Name field. Choose the slide layout from the "Select an Auto 
Layout" section. 
Click OK. 

 
Selecting Slides 

 
 
 
 
 
 
 
 
 
 
 
 
 
A new slide tab appears at the bottom of the workspace for each inserted slide. Click on a 
slide tab to select and display that tab. 

 
Formatting a Page 
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Go to the Format menu and click "Page..." 
In this window you can change the format, the orientation and the margins of the page. 

 
 
 
 
 
 
 
 
 
 
 
 
 
Formatting Slides 
Select "Modify layout..." from the Format menu. The Modify Slide window appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Modify the layout by choosing a new layout from the "Select an Auto Layout" section. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Workspace views 
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Drawing View is the main view for creating individual slides. Use this view to format and design, 
add text, graphics, and animation effects. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Outline View shows topic titles, bulleted lists, and numbered lists for each slide in outline 
format. This view lets you rearrange the order of the slides, edit titles and headings, rearrange the 
order of items in a list, and add new slides. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Slide View shows a small version of each slide in order to rearrange the order of slides, produce a 
timed slideshow, or add transitions between slides. 
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Notes View lets you add notes to each slide that are not seen when the presentation is shown. 
You can print these notes and refer to them while giving a presentation. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Handout View reduces several slides of the presentation and efficiently rearrange slides in this 
view by simply dragging and dropping them. 
Running the slide show 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Editing slides 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Inserting Text 

 

Click on Text icon in the main toolbar. Click on the slide and drag to draw a box, release the mouse 
when finished. The cursor appears in the text box which is now in edit mode. Type the text in the 
box. Click outside the text box to deselect it. 
Formatting Text 

 

The text must be selected before it can be formatted: 

To format all text in a text box, click on the text, then click once on the border of the text box. Now 
any formatting changing will apply to all text in the box. To format only a part of the text, click 
once on the text, then select the part to be formatted by clicking and dragging (highlighting) over 
it. Formatting changes will apply only to the selected text. 
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To view the Character Formatting options, select "Character..." from the Format menu or click the 
Character button on the Object Bar. 

 

 
 

 
 

 
In this window you can specify the font, the typeface and the size of the text. At the bottom of the 
window there is a preview of the selected font. 
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To view the Paragraph Formatting options, select “Paragraph..." from the Format menu or click 

the Paragraph button on the Object Bar. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
In this window you can specify options about paragraphs. 
Creating Bulleted/Numbered Lists 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
To create a bulleted or numbered list from AutoLayout text boxes, insert a new slide or modify 
the current one and then select an AutoLayout that contains a numbered list. 

Click in the box that reads "Click to add an outline" Type the the text, then press Enter to start a 

new bulleted line or the next sequential numbered line. Press Shift + Enter to start a new line 

without creating a new bullet or number. 

Creating a new outline level 
Press tab. Each time you press tab the line indents to the new outline level. Pressing Enter 
creates a new line at the same level as the previous one. 

 

Changing bullet type 
Click in the list, and then click on the gray border of the text box so that just the green 
resizing handles are displayed. Select Numbering/Bullets from the Format menu or click on 
the Numbering Symbols button. Click a bullet style to choose it. Click OK. 
Changing the Slide Background 

 

To change the slide backgrounds select "Page..." from the format menu and then select on the 

background tab. 

Choose the type and style of background desired. Click OK. A message box appears asking: 
 

"Background settings for all Pages?" 

Click Yes if you would like the background appear on all the pages, or No if you would like the 

background to only appear on the selected slide. 
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If you choose Yes all slides have the same background. 
Importing Graphics 
To insert an image select "Graphics..." from the Insert menu. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Choose an image to insert in your document and click Open. If the preview checkbox is 
selected, a preview of the image content is displayed on the right. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You can resize the image just by dragging  one of the eight green points surrounding the 
picture. 
When the move cursor  appears over the image you can move the 
picture. To delete an image, click on it and then press Delete. 
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Slide Transitions and Animations 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Slide Transitions 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Slide transitions are the effects that take place when a slide gives way to the next one in the 
presentation. You can apply a different transition to all slides in the presentation or apply 
different transition to any single slide. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
There are two ways to add a transition. First way: add a transition from the Slide View. When 
you switch in this mode, the Object Bar presents many options for choosing and controlling 
slide effects. 
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Chapter-4 

Open Office Cal-C 
 
OpenOffice is an open source Office Suite package originally designed by Sun Microsystems. 
OpenOffice is much like Microsoft Office but free to use. The software can be freely downloaded 
and used. OpenOffice Calc is much like using Microsoft Excel. 
What is a Spreadsheet? 
A spreadsheet is the computer equivalent of a paper ledger sheet. It consists of a grid made 
from columns and rows. It is an environment that can make number manipulation easy and 
somewhat painless. Spreadsheets are made up of columns, rows, and cells (intersection of a 
column and row. A cell can contain data including text (strings or labels), numeric data, and 
formulas. 
Starting Open Office Calc 
Procedure: 
1. Click Start, Programs, OpenOffice.org 3.2, OpenOffice Calc. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Creating a New Document 
Procedures 
1. Type CTRL+N on your keyboard (hold down the CTRL key and type N). 
2. Select File, New, Spreadsheet from the Menu Bar OR 
3. Click on the New Document Icon on the Function Bar and select Spreadsheet. 
Entering Data 
Procedures 
To enter text, values or a formula: 
1. Click on the cell you wish to enter information. 
2. Type the information. 
3. Press the ENTER key on the keyboard or press one of the arrow keys. 
Selecting (Highlighting) Cell(s) 
To Select One Cell 
Procedure 
1. Click in the cell. (The active cell is already selected.) 
To Select a Range of Cells (e.g. A1:G5) 
Procedures 
1. On the first cell of the range (e.g. A1), click and hold the left mouse button while dragging the 
mouse to the last cell of the range (e/g. G5). 

2. All cells will turn black except the first cell will remain white. 
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To Select a Column or Row 
Procedure 
1. Click on the column or row heading in gray. 
Deleting Cell(s) 
Procedures 
1. Select the cell(s) you wish to delete. 
2. Press the DELETE key on the keyboard. The following window will appear. 
3. Check the boxes of what you wish to delete (e.g. checking Formats will delete things like bold, 
italics, font color, borders). 
4. Click the OK button. 

 
Opening and Saving a File 
The opening, saving, and printing of files are the most common actions in a word processor, 
and therefore, they have to be very easy and accessible. 
Opening a File 
Procedures 
1. Select the File menu, Open from the Menu Bar, OR 
2. Click the Open File icon on the toolbar. 
3. An Open File Dialog box will appear as shown below. From the drop down list (shown by the 
arrow) indicated below, choose the directory that contains the file you wish to open. 
4. When a list of files appears, double click on the filename to open the file. 
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Saving a File 
Procedures 
1. Choose File, Save from the Menu Bar, OR 
2. Click the Save icon on the Function Bar. 
3. If you are saving for the first time, a Save File Dialog Window will be displayed. 
4. Type a filename and choose a location to save the file. 
5. If you wish to save your file as a Microsoft Excel file format, change the Save as type to 
Microsoft Excel 97/2000/XP. 
6. Click the Save button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Cut, Copy, Paste 
Cut and Paste 
This allows the user to move selected text so that it can be placed somewhere else in the 
document or in another document. 
Procedures 
1. Select cell(s) that contain the information you wish to cut (move). 

2. Click the Cut  button on the toolbar or CTRL + X on the keyboard. 
3. Click in the cell where you want to paste the information. 

4. Click the Paste  button on the toolbar or CTRL+ V on the keyboard. 
Copy and Paste 
This allows the user to create a duplicate (copy) of the selected text to be placed somewhere else 
in the document or in another document. 
Procedures 
1. Select cell(s) you wish to cut (move). 

2. Click the Copy  button on the toolbar or CTRL + C on the keyboard. 
3. Place the cursor where to place the cut cell(s). 

4. Click the Paste button on the toolbar or CTRL+ V on the keyboard. 
Formatting 
The formatting action in Open Office is slightly different from other Office applications such as 
Microsoft Office. 
Changing the Font/Font Size 
Font is the style of writing and font size is the size of the text with a 12-point size being 1/6 of an 
inch. 
Procedures 
1. Select the cell(s) you wish to change. 

26



2. On the toolbar, click the       first drop-down arrow to change the font 
and the second drop down arrow to change the font size. 

 

Bold, Italics, Underline 
 

Procedures 
 

1. Select the cell(s) you wish to format. 
2. Click on the attribute icon you wish to apply such as    on the Toolbar. These 
buttons transform the selected text (in sequence from left to right) into Bold, Italics, and 
Underlined. 

 

3. With the cell(s) still selected, click the button again to turn the feature off. 
Cell Alignment 

 

Procedures 
 

1. Select the cell you wish to change. 
 

2. Click on one of the alignment icons     on the function toolbar to modify the text 
alignment (left, center, right, or justified). 
Font Color 
Procedures 

 

1. Select the cell (s) you wish to change. 
 

2. Click the font color button on    the toolbar and pick the color of your choice. 
Background (highlighting) Color 
Procedures 

 

1. Select the cell (s) you wish to change. 
 

2. Click the background color button   on the toolbar and pick the color of your choice. 
Undo/Redo Buttons 
If you perform an action that does not give you the desired result, you can use the 
Undo button  to reverse the last action. Likewise, the Redo button  can be used to redo 
an action that has been undone. 
Spelling/Grammar Check 

 

There is only a spell check available in Open Office. Words spelled incorrectly will be underlined in 

red if the spell check toggle button is turned on. 

Procedures 

1. To turn the spell check on/off as you are typing, click the  button on the toolbar. 
2. If you wish to spell check the entire document in order to make corrections, click 
the button on the toolbar. 
Inserting Pictures 

 

Follow these steps if you wish to add pictures that are saved in a file. 

Procedures 

1. Place your cursor where you want to place a picture. 
 

2. Click Insert menu, Click Graphics, Click From File . 
 

3. Pick the location where the file has been saved. 
 

4. Double click filename to insert into document. 
Note: Use the following toolbar to modify picture attributes. 
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Creating Formulas/Calculations 
You can enter text, numbers or formulae in the cells. Of course, the whole purpose of a 
spreadsheet application is to be able to carry out calculations within these cells. A calculation 
can be simply adding two numbers or taking the average of ten numbers. 

 

Note: A right mouse button click in the box where Sum is written will give you access to a context- 

sensitive menu that proposes other choices, such as mean, maximum, minimum... 

Formula Basics 
 

Just like in Microsoft Excel, formulas are started with an EQUAL (=) sign. (e.g. =b3+b4) 

Use cell references (e.g. b3) instead of actual values (e.g. 56) wherever possible. 

Use FUNCTIONS (e.g. SUM, AVERAGE) to save time when creating formulas. e.g. =SUM(A1:A9) 

Instead of =A1+A2+A3+A4+A5+A6+A7+A8+A9 

By typing “=sum()”, you are telling the software the type of mathematical operation that you 

want to carry out on the referenced cells that are between parentheses. You can also select the 

ranges to be added together using the mouse. After having typed "= sum()" into the target cell, 

click on the first cell and whilst holding the mouse button down, drag the mouse to the last cell of 

the range, and then let go of the mouse button, and you will see the end of the formula inserted in 

automatically into the Formula bar. 

Cell References: It is important to grasp the basics of references when you want to carry out 

calculations on cells containing formulae. A relative reference is a range whose references are 

adjusted when the formula is moved: 

e.g. If you copy the formula "=sum(A1:A9)" to column B, it will become "=sum(B1:B9)" 
 

An absolute reference is used when a calculation has to refer to a precise or absolute cell of the 

spreadsheet. This is written using dollar signs ($) around the cell reference. For example, typing 

$A$1 will make column A and row 1 absolute or fixed. 
 

e.g. If you copy the formula “=$B$3 * B8” from cell C8 to cell C9, the formula would read “=$B$3 
 

* B9. Notice the first part of the formula (=$B$3) did not changed when copied. A good example 

of when you might use an absolute cell reference is when you are calculating the tax on an item. 

The tax (7%) will not change. Each item will be multiplied by the same tax amount. 

 
28



Formatting Cell(s) 
Text Alignment 
Use these buttons   found on the toolbar to change the alignment of cell 
contents. 
Merging Cells 
Sometimes you might want to center a title between many columns. 

 

Procedures 
 

1. Select all the cells in which the title is to be centered between. 
 

2. In the menu toolbar, select Format, Merge Cells, Define. 
3. The cells are now merged into one large cell. Click the Center button  on the toolbar to 
center text within this cell. 
4. Click the OK button. 
Other Formatting Hints 
The 'Cell Attributes' window (click Format, Cells) below includes other tabs for cell formatting 
(e.g. Fonts, Font Effects, Alignment, etc). The function toolbar also contains some of 
these formatting functions. 
Example: Adding Borders 
A border such as a thick dark border can be added to emphasize a range of cells. 

 

Procedures 
 

1. Select the cells for which you want to add a border. 
 

2. Choose the Format menu, Cells and click on the tab called ̀ Borders'. 
3. Choose the style and thickness of the border   you wish to 

use. 
 

Using the Auto Format feature 
 

This feature formats a range of cells with color, borders, font, font size, etc. automatically rather 

than you having to do it one step at a time. 

Procedures 
 

1. Select the range of cells you wish to format. 
2. Select the Format menu, Auto Format, or click the Auto Format button on the toolbar 
to the left of your screen. 

3. Click the format you want from the left side. You can create your own format (see the Add.... 

button to the right) and delete it when you do not want it anymore. By clicking on the More 

button, some additional formatting options appear. If you modify them, the result will be 

presented in the preview image displayed in the Auto Format window. 

4. Click OK. 
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Page Settings 
 

Page settings allow you to change settings related to a page as a whole such as changing the page 

orientation (e.g. portrait - 8.5” x 11” or landscape- 11” x 8.5”), adding headers/footers, and 

margins. 

Changing Page Orientation 
 

Procedures 
 

1. From the menu toolbar, choose Format, Page. 
 

2. Click on the tab Page. 
 

3. At the section Orientation, click on the radio button Landscape. 
 

4. Confirm with OK. 
 

To verify the change in page orientation, click the File menu, Preview. 
Other Page Setting Options 
In the Margins section of the Page tab, you set the margin sizes. If you set them beyond 
the printing area, a message will warn you. 

In the Layout settings section of the Page tab, Page Layout lets you select how to align the 

content of the cells inside the sheet. 

In the Sheet Tab under Scale, the 

Reduce/enlarge printout option allows you to 

decrease or increase the size of the printed page. 

In the Sheet Tab under Scale, the Fit printout 

on  number  of  pages  option  allows  you  to 

determine the exact number of pages on which 

the spreadsheet will be printed. The size of the 

sheets will be adjusted to fit that number of pages. 

Creating Charts 
A chart (e.g. bar chart, pie chart) is a visual 
representation of data contained in a spreadsheet. 

 

Procedures 
 

1. Select the cells you wish to include in the chart. 
 

2. Click the Insert menu, Chart… 
 

3. Step 1: Choose whether you want your chart in the same sheet as your data or a new sheet. 
 

4. Click Next. 
 

5. Step 2: Choose a chart type from the list. 
 

6. Click Next. 
 

7. Step 3: Choose a chart sub-type (variant) from the list. Choose data series in rows or columns. 
 

8. Click Next. 
 

9. Step 4: Add a title to your chart. 
 

10. Click the Create button. 
Printing a File 
It is a good habit to check how the document will look when printed, before printing. It can 
be done by using the Page Preview feature. 

30



Procedures 
 

1. Select File, Page Preview from the menu bar to switch to the Page Preview Mode. 

2. Click Page Preview  button in Page Preview to close Page Preview and return to the 

main document. You may want to print part of your spreadsheet, the entire workbook (all 

worksheets) or even only one sheet. 
Printing a Selected Area of your Worksheet 

 

Procedures 
 

1. Select the cell(s) you wish to print. 
 

2. Select the File menu, Print. 
 

3. In the dialog box that appears, click on the box Selection in ̀ Print range'. 
 

4. Click OK. 
 

Printing a Single Worksheet 

Procedures 

1. Click the File menu, Print. 
 

2. In the dialog box that appears, under Print Range click on the radio button Pages and enter 

the page number that you wish to print. If you wish to print more than one page at a time such 

page 2 and 3, you would enter 2,3. 

3. Click OK. 
Printing Multiple Worksheets 

Procedures 

1. Select the worksheets you wish to print by clicking the first sheet tab at the bottom of the page, 

press and hold the CTRL key on the keyboard and select the remaining sheets you wish to print. 

2. Click on the icon Quick printing in the function toolbar. 
 

3. To undo selected sheets, press and hold the CTRL key and click once more on the sheet tab. 
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Chapter-5 
Open Office Base 

 

 
BASE is a fully featured desktop database management system, designed to meet the 
needs of a broad array of users, from just tracking your personal CD collection, to 
producing a corporate monthly departmental sales report. BASE  offers  wizards  to  help 
users new to database design (or just new to BASE) to create Tables, Queries, Forms and 
Reports, along with a set of predefined table definitions for tracking Assets, Customers, 
Sales Orders, Invoices and much more. 

 
When a personal use database is all you need, BASE offers the full HSQL relational database 
engine, configured for single user, with the data stored right in the BASE file, as well as native 
support for dBase flat files. 

For power users in the enterprise, BASE delivers native support drivers for a variety of multi-user 
database engines: MySQL, Adabas D, MS Access and PostgreSQL. In addition, support for JDBC 
and ODBC standard drivers allows you to connect to virtually any existing database. 

● BASE integrates seamlessly into the rest of the OpenOffice.org suite applications, for 
example: 

● Supplying address book data for mail merge in WRITER using the industry standard LDAP 
protocol, or common address book formats such as Microsoft Outlook, Microsoft Windows 
and Mozilla; 

● Creating linked data ranges in CALC files for data pilot analysis or as the basis for 
charts. 

What is Data? 
 

Data is a collection of facts, such as values or measurements. It can be numbers, words, 
measurements, observations or even just descriptions of things. 

What is a database? 
 

Collection of inter-related data is known as Database. 
 
Create a new database 
1. Start Open Office.org Base. Your screen should look like this: 

 

 
 

2. In the Database Wizard window, click the Create a new database radio button. 
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Then click the   button. 
 

 

 
 
 
 
3. When the Save as window appears, create a new folder in the My Documents folder 
called Practice Base Files. 
TIP: To create a new folder, make sure the My Documents folder appears as the Save In folder. 

Then click the    icon. 
 
 
 
 
 
 
 
4. Double-click the Practice Base Files folder. It should appear as the Save In folder. 

 
5. In the File name box, type: 
Family.odb 
TIP: Base will automatically add a file extension for you when you leave the Automatic file 
name extension box checked. 

 
 
 
 
 
 
 
 
 
 
 
 
 
Click the button. The window for the Family database should open: 
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Identify database elements 
 
Elements of databases 

 

A database stores information in an organized way, and makes it easy to get information in and 
out. 

 

Tables store data within the database. 
Forms make it easy to put data into tables. 
Queries pull out specific data. 
Reports put data in an easily-read format. 

 

 
 
1. In the Database list, click Tables. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. Click Create Table in Design View. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A blank table should open with the columns Field Name, Field Type, and Description: 
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1. Type:  First Name. Then Press the ENTER key on your keyboard. The Design View of the 
table should look like this: 

 
 
 
 
 
 
 
 
 
 
 
 
The field type for First Name can stay Text [VARCHAR]. 

 

1. Click in the box under where you just typed First Name 
 
 

 
 
Type: Last Name 
It should look like this: 

 

 
 
 
 
 
 
 
 
 
 
 
1. Press the ENTER key on your keyboard. 

 

2. In the same way, create the fields: City ,Zip, Phone Number 
The table should now look like this: 

 
 

 
 
 
1. On the Menu Bar, click File, then Save. 
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2. When the Save As window appears, type: My Family in the Table Name box. 
 

3. Click the     button. 
 

 
 
 
 
 
4. When the alert window that reads No primary key appears, click the 

  button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Base will insert an ID field—the Key field—in the table: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. On the Menu Bar, click File, and then Close. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
What is the key field? 

When the alert window popped up, and you clicked the  button, Base added the ID field 
to the table. The ID field is now the table's primary key, or key field. That means it can't contain 
any duplicates. Every table should have a key field. For example, if a hospital keeps a database, 
each patient can have a unique ID number in the key field. That way, if it has more than one 
patient named John Baker, it can easily distinguish John Baker, ID #326 in for a checkup, 
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Create records 
1. Double-click the table My Family in the Tables list. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. Click in the box under the ID column header. 

 
 
 
 
 
 
 
3. Type: 1 
4. Click in the box under the First Name column header. 

 
 
 
 
 
 
 
5. Type: Elvis 
6. Press the TAB key on your keyboard. 
The table should now look like this: 

 
 
 
 
 
 
 
 
 
4. Type: Presley then press the TAB key. 
5. Type: Baltimore then press TAB. 
9. Type: 21212 then press TAB. 
10.Type: 4105551212 then press TAB. 
The table should now look like this: 

 
 
 
 
 
 
 
 
 
Add new fields 

 

1. On the Menu Bar, click File, then Close. 
 

2. Right-click the My Family table. 
 

3. When the menu appears, click Edit. The table should appear in Design View: 
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4. Click the box under Phone Number and type: State 
5. Press the ENTER key. 
6. On the Menu Bar, click File, then Save. 

 
 
 
 
 
 
 
 
 
 
 
 
7. On the Menu Bar, click File, then Close. 
8. Double-click the My Family table. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
9. Click inside the new State field for the first record. 

 
 
 
 
 
 
 
 
10.Type: MD 

 
11.Press TAB until the cursor moves down to a new record.  Record number 1 is saved and 
complete. 

 
 
 
 
 
 
 
 
12.On the Menu Bar, click File, then Close. 
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Chapter-6 
Networking and HTML 

 
 
HyperText Markup Language (HTML) is the predominant markup language for web pages. 
HTML elements are the basic building-blocks of web pages. 
History of HTML 

 
In 1980, physicist Tim Berners-Lee, who was a contractor at CERN, proposed 
and prototyped ENQUIRE, a system for CERN researchers to use and share 
documents. In 1989, Berners-Lee wrote a memo proposing an Internet-based 
hypertext system. Berners-Lee specified HTML and wrote the browser and 
server software in the last part of 1990. In that year, Berners-Lee and CERN 
data systems engineer Robert Cailliau collaborated on a joint request for 
funding, but the project was not formally adopted by CERN. In his personal 
notes from 1990 he lists "some of the many areas in which hypertext is used" 
and puts an encyclopedia first. 

HTML is a language for describing web pages. 
 
· HTML stands for Hyper Text Markup Language 

 
· HTML is not a programming language, it is a markup language 

 
· A markup language is a set of markup tags 

 
· HTML uses markup tags to describe web pages 

 
HTML markup tags are usually called HTML tags 

 
· HTML tags are keywords surrounded by angle brackets like <html> 

 
· HTML tags normally come in pairs like <b> and </b> 

 

· The first tag in a pair is the start tag, the second tag is the end tag 
 

· Start and end tags are also called opening tags and closing tags 
Web Browsers 

 
A web browser is a software application for retrieving, presenting, and traversing information 
resources on the World Wide Web. An information resource 
is identified by a Uniform Resource Identifier (URI) and 
may be a web page, image, video, or other piece of 
content. Hyperlinks present in resources enable users 
easily to navigate their browsers to related resources. A 
web browser can also be defined as an application software 
or program designed to enable users to access, retrieve 
and view documents and other resources on the Internet. 
The major web browsers are Firefox, Google Chrome, 
Internet Explorer, Opera, and Safari. 

HTML Documents = Web Pages 
 

· HTML documents describe web pages 
 
· HTML documents contain HTML tags and plain text 

 
· HTML documents are also called web pages 
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Editing HTML 
 

HTML can be written and edited using many different editors like Dreamweaver and Visual Studio. 
However, in this tutorial we use a plain text editor (like Notepad) to edit HTML. We believe using a 

plain text editor is the best way to learn HTML. 
 

HTM or .HTML File Extension? 
 

When you save an HTML file, you can use either the .htm or the .html file extension. There is no 
difference, it is entirely up to you. 

 

Document Tags 
 

Document tags define the overall structure of an HTML document. 
 
There are four tags every HTML document should have. These tags define that what type of 

document it is, and the major sections. These tags are <HTML>, <HEAD>, <TITLE>, and <BODY 

...>. You may also wish to use the <!DOCTYPE ...> declaration under some circumstances. 
 
A really basic document might look like this: 

 

<HTML> 
 

<HEAD> 
 

<TITLE>A Really Basic Document</TITLE> 
 

</HEAD> 
 

<BODY> 
 

This is a really basic document. 
 

</BODY> 
 

</HTML> 
 
The use some of these tags (particularly <HTML>, <HEAD>) has been an ongoing source of 

controversy for some time. Because these tags don't have any visible effect on a web page, they 

seem useless. In fact, these tags are optional. The standards published by W3C have clearly 

stated all along that <HTML>, <HEAD>, and <BODY ...> are optional. 
 

Formatting Tags 
 

This section includes the tags often used for formatting the HTML text. 
 

 
<Font> 

 

The <font> tag is used to change the format of the text on the web page. The most important 

attributes are as follows: 

· face: The type of font. Common ones include "Time New Roman", "Verdana", and "Helvetica." 
 

· size: This indicates the size of the text. This can be absolute (0 .. 6), or relative ("+1", "+2", ... 

or "-1", "-2" ...) 

· color: This indicates the color of the text. Either the color name or the six-character color code 

may be used to specify color. 

Example 
 

<font size=2 face="Helvetica" color=red>This illustrates the attributes of the font 

tag.</font> 
40



<b> 
The <b> tag will bold the text inside the tag. 

 
<i> 
The <i> tag will italicize the text inside the tag. 

 
<u> 
The <u> tag will underline the text inside the tag. 

Here's an example using <b>, <i>, and <u>: 

HTML: 
This <b>example</b> shows how <i>important</i> it is to use <u>tags</u>. 

 

Header Tags 
The header tags <h1>, ... <h6> allows us to place additional importance on the text within such 
tags. <h1> has the largest size, and <h6> the smallest. Many search engines put additional 
weight on the texts within the header tags. 

 

Example 4 
 
HTML: 
<h1>This is h1 text.</h1> 
<h2>This is h2 text.</h2> 
<h3>This is h3 text.</h3> 
<h4>This is h4 text.</h4> 
<h5>This is h5 text.</h5> 
<h6>This is h6 text.</h6> 
<center> 
The <center> tag causes all the text within the tag to be centered. An example is as follows: 

 
Example 
<center>This is centered text.</center> 

 
<br> 
The <br> tag indicates a line break. This tag is most often used by itself, without a corresponding 
closing tag. 
<p> 

 
The <p> tag indicates a new paragraph. It is the same as <br><br>. This tag is most often used 
by itself, without a corresponding closing tag. 

 

HTML List 
 

This section lists the tags often used with HTML lists: <ol>, <ul>, and <li>. 
 
<ol> 
The <ol> tag specifies that the following list is ordered. 
<ul> 
The <ul> tag specifies that the following list is unordered. 
<li> 
The <li> tag lists each item, whether ordered or numbered. Note that each item is indented. 
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Example: ordered list. 
 
<ol> 
<li>Unordered list 1.</li> 
<li>Unordered list 2.</li> 
</ol> 

 
Example: unordered list. 

 
<ul> 
<li>Unordered list 1.</li> 
<li>Unordered list 2.</li> 
</ul> 
HTML Hyperlink 
<a> 
The essence of an HTML document lies in the first two words: (H)yper(T)ext. In other words, it is 
the ability to link to other documents that makes HTML unique. How do HTML documents link to 
other documents? It does so via the <a> tag. The attributes for the <a> tag are href and name. 
Below we show an example for each: 

 

Example 1: Link to an external document. 
 
<a href="sample.html">This link</a> takes you to a document called "sample.html." 

Example 2: Link to an anchor within the same document. 

HTML: 
<a href="#atag">This link</a> takes you to a pre-determined location on the same page. 

 

HTML Image 
<img> 
The <img> tag is used to embed an image on the HTML document. The attributes are as follows: 
· src: The file path to the image file. 
· width: The width of the image, in pixels. 
· height: The height of the image, in pixels. 
· alt: The text the browser will display when visitors mouse over the image. Search engines 
often places more weight on the text in the alt attribute. 
Example: 
<html> 
<body> 
<h2>Norwegian Mountain Trip</h2> 
<img border="0" src="/images/pulpit.jpg" alt="Pulpit rock" width="304" height="228" /> 
</body> 
</html> 
Internet 
When the computing era took a major leap in the 80s, it was all just about the operating systems 
and the programming languages. It was not long after the computer revolution that a tide, a 
blizzard of communication, arrived. This technology now makes the computers look lifeless if they 
don't have it. Connecting the corners of the cobwebbed world even from its remotest corner is the 
When the computing era took a major leap in the 80s, it was all just about the operating systems 
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'Internet'. 
 
Internet: What is Internet? 

 

 
The Internet can be defined as the wired or wireless mode of communication through which one 
can receive, transmit information that can be used for single or multiple operations. 
History 
This marvelous tool has quite a history that holds its roots in the cold war scenario. A need was 
realized to connect the top universities of the United States so that they can share all the research 
data without having too much of a time lag. This attempt was a result of Advanced Research 
Projects Agency (ARPA) which was formed at the end of 1950s just after the Russians had 
climbed the space era with the launch of Sputnik. After the ARPA got success in 1969, it didn't 
take the experts long to understand that how much potential can this interconnection tool have. 
In 1971 Ray Tomlinson made a system to send electronic mail. 
1973 saw the preparations for the vital TCP/IP and Ethernet services. At the end of 1970s, 
Usenet groups had surfaced up. By the time the 80s had started, IBM came up with its PC based 
on Intel 8088 processor which was widely used by students and universities for it solved the 
purpose of easy computing. By 1982, the Defence Agencies made the TCP/IP compulsory and the 
term “internet” was coined. The domain name services arrived in the year 1984 which is also the 
time around which various internet based marked their debut. Soon after the world got over with 
the computer worm, World Wide Web came into existence. Discovered by Tim Berners-Lee, 
World Wide Web was seen as a service to connect documents in websites using hyperlinks. 
In 1992, internet browser called “Mosaic” came into existence. One of the very popular internet 
browsers, Netscape Navigator made its debut in 1994 which ultimately went to compete with 
Microsoft's Internet Explorer. 
The advantages of Internet 

 

Following are the advantages provided by the Internet: 
 
1) Information: The biggest benefit offered by the Internet is information. It functions as a 
valuable resource of information. You can find any type of information on any subject with the 
help of the search engines like Yahoo and Google. 

2) Communication The primary goal of the Internet is communication. It has done extremely 
well in this field, however the development process is still going on to make it more dependable 
and quick. By sending an e-mail, we can contact a person who is physically present thousand 
miles away within the fraction of a second's time. 

 

3) Entertainment Internet functions as a popular medium of entertainment. A wide variety of 
entertainment including video games, music, movies, chat room, news and others can be 
accessed through the Internet. 

 

4) E-commerce: E-commerce is the idea that is implemented for any form of commercial 
strategy or business transactions that entails transmission of data from one corner of the world 
to another. E-commerce has become a fantastic option through which you can shop anything. 

 

5) Formation of communities Internet helps in formation of communities or forums. Here a 
number of people can participate in different types of debates and discussions express their 
views and gather valuable knowledge. 
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6) Services A variety of services are offered via Internet, for example job searching, online 
banking, buying movie tickets, hotel reservations and consultation services etc. When you 
avail these services offline, they become more expensive. 

 

NETWORK ARCHITECTURE 
 
It is a network communication design in which the physical components of computers are 
arranged in a sequence so that they can communicate with each other. Network is a combination 
of hosts, applications, routers, hardware, software and links of media. Network architecture is a 
guideline and technology for designing building  and managing a network. 

Components of Network Architecture 
 

There are six basic network architecture components such as servers, proxies, clients, 
command consoles, server modules and cores. The server is the backbone of any network. 
The role of servers in network architecture is to communicate with proxies and other peered 
servers. They are at the top layer of the network and they do not communicate directly with 
client. Moreover servers receive complete projects and tasks .proxies can be termed as the 
focal point of the network because it facilitates the communication of the devices. Proxies 
usually perform buffering and they also communicate with the others of its type to share the 
loads of the network. The client systems are the workers of the network. They receive tasks, 
they interact with the users and they perform user applications. Command consoles are the 
network guidelines which provide assistance to users about how to control the authorize 
network nodes. The core is the real work done in the system. The cores are verified within 
the network and with the clients to prevent bad cores. Server modules handle the particular 
tasks of the server. Server module is generally registered with the server libraries; this would 
help the server to perform the needed task. 

WWW 
 

The World Wide Web is a system of interlinked hypertext documents accessed via the Internet. 

With a web browser, one can view web pages that may contain text, images, videos, and other 

multimedia, and navigate between them via hyperlinks. 

Electronic mail 
 

Electronic mail commonly known as email or e-mail, is a method of exchanging digital 
 

messages from an author to one or more recipients. Modern email operates across the Internet or 

other computer networks. Some early email systems required that the author and the recipient 

both be online at the same time, in common with instant messaging. Today's email systems are 

based on a store-and-forward model. Email servers accept, forward, deliver and store messages. 

An email message consists of three components, the message envelope, the message header, 

and the message body. The message header contains control information, including, minimally, 

an originator's email address and one or more recipient addresses. 

UTILITIES 
 

Dictionary: 
 

Tie up: A temporary stoppage or slowing of business, traffic, telephone service, etc., due to 
such incidents as a strike, storm, or accident. 
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Strand: A single filament, such as a fiber or thread, of a woven or braided material 
 

Services on the web 
 

A Web service is a method of communication between two electronic devices over the web. The 

W3C defines a "Web service" as "a software system designed to support interoperable machine- 

to-machine interaction over a network". It has an interface described in a machine-processable 

format. 

Newsgroups 
 

Newsgroups are Internet discussion forums where groups of users with common interests gather 

to talk about everything from software to comic books to politics. Unlike e-mail messages, which 

are visible only to the sender and specified recipients, newsgroup messages can be read by 

anyone who views the group that they're posted in. Newsgroups are international in scope, with 

participants from all corners of the Internet. 

E-Commerce 
 

E Commerce is short for Electronic Commerce. It stands for businesses that transfer info across 

the internet and it allows consumers to exchange services and goods electronically. 

E-commerce (electronic commerce or EC) is the buying and selling of goods and services on the 

Internet, especially the World Wide Web. In practice, this term and a newer term, e-business, are 

often used interchangeably. For online retail selling, the term e-tailing is sometimes used. 

File Transfer Protocol 
File Transfer Protocol (FTP) is a standard Internet protocol for transmitting files between 
computers on the Internet. Like the Hypertext Transfer Protocol (HTTP), which transfers 
displayable Web pages and related files, and the Simple Mail Transfer Protocol (SMTP), which 
transfers e-mail, FTP is an application protocol that uses the Internet's TCP/IP protocols. FTP is 
commonly used to transfer Web page files from their creator to the computer that acts as their 
server for everyone on the Internet. It's also commonly used to download programs and other 
files to your computer from other servers. 
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