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1. IT CONCEPTS
This section explains about computer, its components and memory. A computer is an electronic machine that is used for 
manipulating data according to the list of instructions provided by the user. A computer system can be explained in easy way 
by describing its four basic operations. Computers are making a great impact on our day to day activities. In the current 
technological world, they are playing an important role in all the functions of our day to day life.  Computer has numerous 
advantages in the field of science and technology. Some of its characteristics make it so amazing that it has made its way to 
even space science. 

HISTORY OF COMPUTER 

The development of modern day computer is the result of a series of various generations of computers. In each generation, 
some extra features and technical advancement have been added.  

Generation of Computer 

First Generation Computers (1940-1956): The first generation computers used vacuum tubes for circuits and magnetic drums 
for the memory storage. First generation computers were very large and take enormous space. These computers consumed 
large amount of electricity, and generated a lot of heat. First generation computers used machine language. The Universal 
Automatic Computer (UNIVAC) and Electronic Numerical Integrator Analyzer and Computer (ENIAC) computers are examples 
of first generation computing devices.  

Second Generation Computers (1956-1963): The second generation computers used transistors and magnetic core for 
memory storage. Use of transistors made the computers smaller, faster, cheaper, energy efficient and more reliable than the 
first generation computers. Transistors were a vast improvement over the vacuum tubes but still generated great amount of 
heat that subjected computer to damage. Second generation computers used assembly language.  

Third Generation Computers (1964-1971): The third generation computers used integrated circuits. They were smaller and 
cheaper than the previous generation computers. 

Fourth Generation Computers (1971-Present): The fourth generation computers used microprocessor. Microprocessor 
consisted of thousands of integrated circuits built onto a single silicon chip. 

Fifth Generation Computers (Present): The fifth generation computers are based on artificial intelligence. They are still in 
their developmental phase.  

Characteristics of Computer 

The following are the characteristics of computer: 

• Hard Work: A computer works very hard and does not get tired.
• Accurate: A computer is always correct. It commits mistake only if we commit mistake. If we don’t commit mistake,

the computer will also not commit mistake.
• Speed: A computer is very fast in its work and does everything correctly and quickly.
• Storage Capacity: A computer has a large memory and it can remember many things for a long time.
• Abilities: We can do many things on the computer like sums, drawing pictures, writing letters, etc.
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Types of Computer 

Microcomputers or Personal computers: Microcomputers are small in size. They can fit on a desk top. These computers are 
used by a single person at a time.  

Minicomputers: Minicomputers have large memory and are costlier than microcomputers. These computers can be used by 
many people at the same time. 

Mainframe computers: Mainframe computers are very large in size. These computers have very large memory and are very 
costly. They operate at very high speed. They can be used by several persons at the same time. They are used at places such 
as banks, research organisations, etc. The largest and fastest Mainframe computers are called Super computers. 

APPLICATIONS OF COMPUTERS IN VARIOUS FIELDS 

Computers have their application or utility everywhere. We find their applications in almost every sphere of life–particularly 
in fields where computations are required to be done at a very fast speed and where data is so complicated that the human 
brain finds it difficult to cope up with. 

Computers now-a-days are being used almost in every department to do the work at a greater speed and accuracy. They can 
keep the record of all the employees and prepare their pay bill in a matter of minutes every month. They can keep automatic 
checks on the stock of a particular item. Some of the prominent areas of computer applications are: Railway / Airlines, 
Science and research, Tourism, Banks, Industry, Transportation, Education, Entertainment and so on 

Understanding Computer System 

A computer is an electronic machine that is used for manipulating data 
according to a list of instructions provided by the user. A computer system 
can be explained in easy way by describing its four basic operations. These 
operations are: 

• Input: Is supplied to the computer with the use of a keyboard, a
mouse or another input device. These input devices may be called
as peripheral devices.

• Processing: Is done inside the computer in an area called the
Central Processing Unit (CPU). Processing is the process of
converting input to the desired output.

• Storage: Is the area to store information in the system.
• Output: Is the result of computer processing. Output may be

viewed on a monitor screen, heard through speakers, printed on
printers and so forth. Output devices may be considered as
hardware and peripheral devices.

Input Devices

The devices used for entering data into a computer are called input devices. These devices receive instructions and transfer 
them for processing. The devices also translate the given instructions into electrical signals (digital signals) which are 
understood by the computer.  

One can communicate with a computer using the I/O devices interfaced to it. Various input devices used by computers are: 

• Mouse
• Keyboard
• Joystick
• Digital camera
• Web camera
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• Microphone

Mouse 

A mouse is a pointing device that is used to control the movement of the cursor or pointer on a display screen. When a 
mouse is rolled on a flat surface, the mouse pointer on the screen also moves in the corresponding direction. The movement 
of the mouse ball is translated into signals that tell the computer how and where to move the screen pointer. 

Mouse contains at least one button and sometimes as many as three, which have different functions depending on what 
program is running. Some latest mouse also includes a scroll wheel for scrolling through long documents. 

Types of Mouse 

The three basic types of mouse are: 

• Mechanical mouse: Is a mouse that has a rubber or a metal ball on its underside, which can roll in all directions.
The mechanical sensor within the mouse detects the direction of the rolling ball and makes the movement of the
screen pointer accordingly.

• Optomechanical mouse: Is a type of mouse, which is very much similar to mechanical mouse, except that it uses an
optical sensor to detect the movement of the ball.

• Optical mouse: Uses a laser beam to detect the movement of the mouse pointer. It responds more quickly and
precisely than any other mouse.

Keyboard

The keyboard is an input device. It looks like a typewriter. It allows you to 
communicate with the computer by passing your data or instruction into the 
computer. The output of the key switches is fed to electronic circuit known as the 
keyboard encoder, which converts them into binary coded values. The values are 
then fed into the computer, which interprets the key that is pressed.  

Joysticks 

A joystick is a control device that enables a user to move an object on the screen. It is also known as 
paddle. It is mainly used for playing video games. It contains a small vertical lever, also called the 
stick, which is set into two crossed grooves and can be moved left, right, forward and backward. The 
movement of the stick is sensed by a potentiometer and the instructions are sent to the CPU for the 
movement of the object on the screen.   

Digital Camera 

The digital camera is an input device, which stores images digitally. It converts light intensities 
into discrete numbers for storage on a storage media such as a hard disk or a flash disk (a type 
of secondary storage device). It does not require film to store or record the images as it stores 
images digitally, which can be downloaded to a computer system and can be printed. The main 
difference between a film based camera and a digital camera is that the digital camera has no 
film. Photo making is inexpensive and fast because it does not require film processing. Instead of film, digital cameras use a 
solid state device called an image sensor, which is usually a Charge Couple Device (CCD). It records colour images as 
intensities of red, green and blue that are stored as variable charges in a CCD matrix. The size of the matrix determines the 
resolution and colour depth.  

Web Camera 

The Web camera is growing as an integral input device of computer, which is used for taking instant 
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picture of the object. It is very much similar to a digital camera as it works in the same way as the digital camera with digitised 
images. The only difference is you cannot use Web camera without attaching it to the computer system but digital camera 
can be used with or without attaching it to the computer system. Web camera is specially used for video conferencing or 
conversation on the Internet.  

Microphone 

The microphone is a special input device that converts spoken words into computer understandable code and vice versa. This 
device converts data from the computer to the spoken words or sentences as well. Speech is digitised first then matched 
against the dictionary of coded waveforms, and finally matches are converted into text. 

The microphone works in tandem with a sound card.  You can speak your words or input a sound using microphone. In some 
speaker dependent systems, you need to enunciate samples into the system in order to tune it to your individual voice. The 
sound card translates the electrical signal from microphone into a digitised form that the computer can store and process. 
Microphones are useful because such systems have replaced human operators for telephone services. They also provide help 
to convert the typed text into speech and broadcast it over the speakers.  

Output Devices 
The output devices receive machine understandable (binary code) output from the processor and convert it into user 
understandable form. The output generated by the output devices is used by the users as final output or a machine input for 
another processing cycle. 

Various output devices are: 

• Visual Display Unit (VDU) 
• Printer 
• Scanner 

Visual Display Unit (VDU) 

VDU is the most popular output device, usually called as monitor, which is used to display the text or 
other objects on the screen. It is used to display the images generated by the computer's video 
adaptor. It provides a way to you for communicating with the computer. The monitor is attached to the 
video adaptor by a cable and the term monitor usually refers to a VDU. On the monitor, you can see the input data or 
information supplied to the computer, as well as the final result obtained after processing.  

Printer 
The printers are the primary output devices, which are used to prepare permanent documents of output, 
called hard copy of output. It is one of the most conventional and useful methods for delivering 
information using printed characters. The types of printers can be classified on the basis of two distinct 
methods of producing print: 

• Impact printers: The printers, which print through striking the characters against the ink pads or 
ribbons so that the impressions are printed on the paper, are known as impact printers. These 
printers have a mechanical contact between the printer head and paper, such as line printer and 
character printer.  

• Non impact printers: The printers, which print using laser, magnetic or thermal technology, are 
known as non impact printers such as electromagnetic printers, thermal printers, desk jet 
printers and laser printers.  

Scanners  
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A device that captures a text document or an image and converts it into a digital image is called a scanner. Two types popular 
scanner are handheld scanners and flatbed scanners. The flatbed scanner is more popular now a day.  

A flatbed scanner has a glass pane. When the images are placed on this pane, a bright light illuminates the pane and the 
scanner head moves across the image. It reads as a series of light and dark spots. Only charge coupled devices can see the 
image because the light is reflected on that device. If the image is transparent then flatbed scanner can not work, it requires 
special accessories that illuminate them from the upper side.  

Handheld scanners work like a manual device. When the scanning starts, it drags across the surface. It has a start button 
which is held by the user for the scanning duration. Some handheld scanners also have a small window that use for scanning 
the document.  

Central Processing Unit

The computational and control unit of a computer is known as Central Processing Unit (CPU).  It is the device that interprets 
and executes instructions.  

Single chip central processing unit is called microprocessor. It made the existence of personal computers and workstations 
possible. The CPU or microprocessor, in the case of a microcomputer, has the ability to fetch, decode and execute 
instructions. It also transfers information to and from other resources over the computer's main data transfer path known as 
bus. By definition, the CPU is the chip that functions as the brain of a computer. Microprocessor or CPU is a piece of 
electronic circuit that uses digital logic to perform the instructions of program. The various components of CPU, which control 
the whole processing of the system, are: 

• Semiconductors: Is a material that is neither a conductor nor an insulator but can be chemically altered to be
either one, when required. A microprocessor is made of layer upon layer of electronic circuits that are liberally
carved out of silicon. Silicon is the primary building block used in manufacturing the electronic circuits (chips).
These silicon chips are used to conduct the processor and ultimately the computer or electronic circuits because it
is an excellent semiconductor.

• Conductors and insulators: A conductor is the material or element or object, which allows electric current to pass
through it such as copper or aluminum. These elements have free electrons through which the current can pass.
While insulator does not allow an electrical current to pass through such as rubber or glass. Both the conductor
and insulator are used in microprocessor accordingly.

• Integrated circuit: An Integrated Circuit (IC) is a combination of electronic components such as transistors,
capacitors and resistors. It is designed to perform some logical functions based on timer, counter and memory. The
basic building block of an IC is a logic gate. A logic gate performs the Boolean algebra.

Introducing Primary Memory

The storage system of computers includes primary memory and secondary memory. Primary memory or Random Access 
Memory (RAM) or temporary memory is the main memory of computer, which is used to store data temporarily while the 
secondary memory provides a means of permanently storing the information. Memory is a circuitry that allows information 
to be stored and retrieved. In general, memory can refer to external systems such as disk or tape drives. It is basically the fast 
semiconductor storage or RAM, which is directly connected to the processor. The two types of memories are:  

• Random Access Memory (RAM)
• Read Only Memory (ROM)

Random Access Memory (RAM) 

RAM is the main memory of the computer. RAM provides permission to read and write over the memory chip. While the 
ROM permits only read permission, RAM is volatile by nature, which means that it needs continuous flow of electricity to 
keep its content safe.  Otherwise, as soon as the power is off, the content in the RAM is lost. Therefore, due to its volatile 
nature it is also referred to as temporary memory.  

7



Various types of RAM are: 

1. Dynamic RAM (DRAM): Is a form of semiconductor RAM. Dynamic RAM stores
information in integrated circuits that contain capacitors. DRAMs are more
commonly used than static RAMs even though they are slower. A DRAM can
hold approximately four times as much data as a static RAM chip of the same complexity.

2. Static RAM (SRAM): Is a form of semiconductor memory. SRAM storage is based on
the logic circuit known as a flip-flop, which retains the information stored in it as
long as there is enough power to run the device. A static RAM chip can store only
about one fourth as much data as a DRAM chip of the same complexity. It does not
require refreshing and is usually much faster than DRAM. It is also more expensive.
SRAMs are usually reserved for use in caches.

3. Rambus DRAM (RDRAM): Is a new powerful memory technology produced by
Rambus Inc. It is very expensive RAM chip. It provides high data transfer
speed; it can transfer data at up to 800 MHz.

Read Only Memory (ROM) 

ROM is a type of memory that stores the instructions, which are necessary for starting up the computer. It cannot be written 
like RAM because as the name implies they are read only memories. But, now few versions of ROM have been launched that 
include multiple enhanced features of reading and writing.  

Various types of ROM are: 

• Programmable Read Only Memory (PROM): Is a type of ROM chip, which allows you to write.
But, it provides permission to write on chip only once. The PROM cannot be updated further, if
it has been used.

• Erasable Programmable Read Only Memory (EPROM): Is a special type of PROM that
provides update permission on a PROM memory chip. Unlike PROM, here you can erase the
already programmed chip by exposing it to ultraviolet light.

• Electrically Erasable Programmable Read Only Memory (EEPROM): Is again a special type of
PROM. It also allows you to erase the instruction and reprogram the chip like EPROM. But,
here you can erase the chip by exposing it to an electrical charge.

Introducing Secondary Memory 

There are several types of secondary storage devices. The most common type of secondary storage device is disk. It is the 
permanent storage medium for either storing data or a program. The disk can be an internal hard disk, which is housed within 
the system unit or an external floppy disk. In addition, the Compact Disk - Read Only Memory (CD-ROM) is another type of 
secondary storage device commonly available in all the computer systems. The data storage devices include: 

• Floppy Disk Drive (FDD)
• Hard Disk Drive (HDD)
• Compact Disk (CD)
• Universal Serial Bus (USB) Drive
• Thumb Drive – A USB Drive
• Tape Drives 

Hard Disk Drive (HDD) 

The hard disk is a permanent storage media, which is used to store huge volume of data. It is the most 
important and commonly used storage device. It is used to record computer data magnetically. A hard 
disk is physically composed of a series of flat and magnetically coated platters stacked on a spindle.  A 
hard disk drive consists of a stack of inflexible magnetic disks mounted on a motor. As the disks spin at 
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high speed, read/write heads at the end of a metal fork swing in and out to access the sectors of the disks. 

Compact Disk (CD) 

The Compact Disk (CD) is a data storage device used for containing data recorded in digital form. It is a type of storage 
medium that resulted from audio technology.  A standard CD can hold a huge amount of information about 650 Megabytes 
(MB). This means that a single disk can carry more than an hour of high quality music or an entire feature film. It can store 
huge amount of text, graphics, audio and video. The most common type of CD, the audio CD, is increasingly popular as a 
means of providing the consumer with high quality recordings of music.  The Compact Disk - Read Only Memory (CD-ROM) is 
ideal for distributing information such as encyclopedias and other reference materials.  

The two types of CDs available are:  

• Compact Disc - R (CD-R): Is recordable CDs, called CD-R, which can be written only once and after writing they
becomes read-only discs. 

• Compact Disk-RW (CD-RW): Can be overwritten repeatedly by a computer. You can erase the previous data and
write the new content on the disc. 

The following figure shows the CD & CD-ROM drive: 

(I) (II) 

Universal Serial Bus (USB) Drive 

The Universal Serial Bus (USB) drive is a serial bus standard based interface, which is used to connect the 
portable memory devices in various systems such as video game consoles, Personal Digital Assistants 
(PDAs), portable Digital Versatile Disks (DVDs), media players, cell phones, televisions, home stereo 
equipments and car stereos. USB does not require any expansion card or device driver to connect any 
peripheral devices to the computer. The host enumerates and recognises USB and loads the device driver 
that it needs. It can connect peripherals such as mouse devices, keyboards, PDAs, game pads, joysticks, scanners, digital 
cameras, printers, external storage and networking components. For many devices, such as scanners and digital cameras, USB 
has become the standard connection method.   

Thumb Drive - A USB Drive

A thumb drive is a portable memory storage device. It is a re-writeable storage device, which can store the memory data 
without a power supply unlike RAM. Thumb drive can fit into any USB port on a computer. It is also known as flash drive. A 
user can plug the drive into a computer and will not have to restart it to access the thumb drive. The drives are small in size 
like a human thumb and are very stable memory storage device. The thumb drive is available in storage size of up to 8 
gigabytes.  

Tape Drives 

The tape drive is a storage device that reads data from one location and writes it onto a tape such as magnetic tape or a 
punched card. It is typically used for storage of data, which is stored on hard drives. Tape media generally has a favourable 
unit cost and long archival stability. Various features of tape media are: 

• Is used as a data transfer media but its transfer speed is varying considerably. The fast tape
drives can transfer as much as 20 MB per second.

• Has data capacity that ranges from a few hundred kilobytes to several gigabytes.
• Is typically used for archival storage of data stored on hard drives.
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The disadvantage of tape drives is that they are sequential access devices. Sequential access means if you want to read any 
particular block of data, you need to read all the preceding blocks. This makes them too slow for general purpose storage 
operations. However, they are the least expensive media for making backups.  

Units of Memory

A bit is a binary representation; either 0 or 1 and combination of bits make up the bytes, kilobytes and so on, where:  

1 Nibble = 4 Bits 

1 Byte = 8 Bits 

1 Kilo Bytes (KB) = 1024 Bytes 

1 Mega Bytes (MB) = 1024 KB 

1 Giga Bytes = 1024 MB 

The more memory you have in general, the more each program can do. Memory is measured in small groups of data called 
bytes. Each byte consists of eight bits. The byte is the basis of all the measures dealing with the computer. 

Describing the Basic Concepts of Direct Data Entry

There are devices, which read or detect the information and convert it into an electronic signal directly. These are known as 
direct entry devices.  This whole phenomenon includes some kinds of sensors, which make it possible. 

Magnetic Ink Character Recognition (MICR)

MICR is a technique, which is used to verify the originality of paper documents, especially cheques. It provides a secure and 
high speed method of scanning and processing information. It is a character recognition system that uses special ink and 
characters. When a document that contains this special ink needs to be read, it passes through a machine called MICR. This 
machine magnetises the ink and then translates the magnetic information into characters. It is used in bank for verifying 
cheques and deposit slips. In other words, MICR readers detect the characters and convert them into digital data. The use of 
MICR can enhance security and minimise the losses caused by various types of crimes.  

Optical Character Reader (OCR) 

Ocr is a device, which scans the printed textual material then converts it into an electronic form and stores it in a file on the 
computer or disc. It follows the mechanism in which scanned images are electronically read and converted into editable text 
such as american standard code for information interchange (ascii) format. Ocr performs multiple operations, such as: 

• Creates text searchable files for digital collections in libraries, businesses and government agencies.
• Provides help to process cheques and credit card slips.
• Scans stylised fonts or text found in magazines and newspapers into a computer.

Optical Mark Reader/Recognition (OMR) 

Omr is a device that detects predefined marks on a certain portion of a paper. It allows electronically extracting intended data 
from marked fields such as checkboxes and fill-infields on printed forms or documents. Omr devices are generally used in 
applications where large numbers of hand filled forms need to be processed quickly and with great accuracy such as surveys, 
reply cards and questionnaires. 
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Light Pen 

The light pen is a pointing device, which is used to choose objects or commands on the screen either by 
pressing or moving it on the surface of the screen or by pressing a small switch on its side. It is a small pen 
shaped wand that uses light sensor. The light sensor senses the light emitted from a limited field of view 
when it comes in front of a graphic element or object of the screen. 

The light coming from the screen causes the photocell to respond by generating a pulse. This electric response in shape of a 
pulse is transmitted to a processor that identifies the pixel, the light pen is pointing.  To identify a specific location, the light 
pen is very useful. It is also used to draw images on the screen.  

Bar Code Reader

The bar code reader is an optical input device, which is used to read the values or quantities printed on the 
products in the form of vertical bars known as bar code. Bar code is recorded on the product by the 
manufacturers and usually carries the inventory stock number or unique product number. The coding 
scheme called Universal Product Code (UPC) for recording the data is based on the width of the bars and 
the space between them. The bar code reader uses a laser beam to read and interpret bar code. The reader emits a laser 
beam that reflects on the bar code. The bar code reader consists of a light sensitive detector that identifies the bar code 
image and converts it into a numeric code that can be processed further.  

COMPUTER LANGUAGES

To communicate with the computer, you need to know a language that a human and computer can understand. A 
programming language is designed to express calculations that can be performed by a machine, particularly a computer. 
Programming languages can be used to create programs that specify the behaviour of a machine. Many programming 
languages have some form of written specification of their syntax and semantics since computers require precisely defined 
instructions. Therefore, a programming language is a set of instructions that a computer can understand to perform a task. In 
early ages, the Beginner's All-purpose Symbolic Instruction Code (BASIC), Common Business Oriented Language (COBOL) and 
Formula Translation (FORTRAN) are some of the programming languages that were developed.  

Introducing Computer Languages

A computer programming language is a language that enables you to write programs to control the operations of a computer. 
When you write a program using a particular programming language, you need to follow the syntax of that language. A 
programming language also provides operators that enable you to perform various tasks, such as computing and 
manipulating values of variables, compare values of different variables of same data types, and test multiple conditions. 

Low Level and High Level Languages 

Low level language is a type of programming language that provides little or no abstraction from a computer's 
microprocessor. Machine and Assembly languages are the common examples of low level programming language. The main 
features of low level programming languages are: 

• Specifications according to the Central Processing Unit (CPU) which is the brain of any computer.
• Writing a low level program requires time, as well as a clear understanding of the inner workings of the processor.
• Low level programming is mainly used only for very small programs or for segments of code that are highly critical.
• A program written in a low level language can be efficient, making efficient use of both computer memory and

processing time.
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High level language is a type of advanced computer programming language. C, FORTAN, BASIC and PASCAL are some common 
examples of high level language. The main features of high level languages are: 

• Help in faster development of large programs.
• Provide string handling routines.
• Provide object-oriented programming features.
• Provide file input/output.

Assembly Language  

Assembly language is a low level programming language. It is a symbolic representation of machine code. Assembly language 
is designed for specific processors. Main features of assembly languages are: 

• Allow symbolic designation of memory locations.
• Program first must be translated into machine code by a separate program called an assembler.
• Critical sections of programs written in higher level languages can be written in assembly to speed up sections.
• Changes should first be made in the source code of assembly language and then reassemble it to create a new

object program.

Introducing Translators

Translators are the programs / utilities, which are basically used by programmers to convert high or middle level language to 
lower level language. We need this conversion because computer understands instructions only in the form of low level 
language (machine language). Translators come in the following three variants: 

• Assemblers
• Interpreter
• Compilers 

Assemblers

Assemblers translate the assembly language code (source program) into machine language code (object program). After 
assembling, a linker program is used to convert the object program into an executable program. The Microsoft Assembler 
program (MASM) and Borland Turbo Assembler program (TASM) are two popular assemblers. Assemblers are used mainly in 
development of system software. 

Interpreters 

Instructions of a high level language are coded in many statements. At the time of their execution, they are converted 
statement by statement into machine code using system software, called Interpreters. For example, programs written in 
BASIC language are executed using Advanced BASIC (BASICA) or GWBASIC interpreters. ere are certain disadvantages of 
interpreters. As instructions are translated and executed simultaneously using interpreters, they are very slow for executing 
large programs. Hence, interpreters are not suitable for most of the applications development. 

Compilers 

As contrast to interpreters, compilers provide faster execution speed. Compilers do not translate and execute the instructions 
at the same time. They translate the entire program (source code) into machine code (object code). The object code is 
converted into executable code using linker. Compilers are widely used in translating codes of high level languages (e.g. 
COBOL, FORTRAN, PASCAL, Turbo/ Quick BASIC, Turbo/ Microsoft C, Java, etc.). As compared to interpreters or assemblers, 
compilers are preferred in development of application software. 

Difference between Assembler and Compiler
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An assembler refers specifically to such a program that takes as its input assembly language. Assembly language is a very 
"low-level" programming language, where short acronyms as used to represent machine instructions. Thus, assembly 
language, very closely mirrors the actual machine code that is being executed, and is only very mildly human readable. 
Assemblers do little more than directly translate the assembly source code into machine code - that is, they don't do 
optimization of their own, as assembly language is meant as a direct representation of the machine code, and thus no 
optimization is required (or, desired).  

A compiler generally refers to any other instance of this concept, but usually means something that take a higher-level 
language (i.e. anything above assembly language) and translates that to machine code. Compilers generally need to be 
significantly smarter than an assembler, as the compiler does a whole lot more work, and thus, has the opportunity to make 
significantly optimizations when doing the source machine code translation. That is, high-level languages allow for the 
expression of concepts of ideas, which make them ideal for humans to write programs in. The compiler must be sophisticated 
enough to take these ideas and convert them into concrete machine code instructions. In addition, better compilers notice 
places where shortcuts can be taken (optimizations) given the overall structure of the input source code. 

Explaining Types of Software

A computer is hardware and it is useless unless it is provided 
with the necessary software. Therefore, all computer users 
must be aware of the basic software concepts besides 
hardware. Software is a program or set of instructions, which 
is required to use the computer. Various types of software 
are available for various applications. The software 
development field is so advanced that day by day existing 
software are becoming outdated and new software are 
coming in the market. Therefore, we must get aware of the 
latest developments in the software industry. Software can 
be categorised basically into the following two categories: 

• System software
• Application software  Software differentiation 

System Software

Software that is required to control the working of hardware and aid in effective execution of a general user’s applications 
are called System software. This software performs a variety of functions like file editing, storage management, resource 
accounting, input/output (I/O) management, database management, etc. Some of the examples of system software are Disk 
Operating System (DOS), Windows, Drivers, etc. This software is developed by System programmers. 

Types of System Software

System software can be further categorised into the following three types: 

• System Management Software (operating systems, DBMS, operating environments, etc.)
• System Development Software (language translators, application generators, CASE tools, etc.)
• System Software Utilities (Undelete command, disk fragmentation tools etc.)

Application Software 

Software that is required for general and special purpose applications like database management, word processing; 
accounting, etc. are called as application software. Some of the examples of application software are MS Office, Games, etc. 
Application software is developed using system software by application programmers. Application software can be further 
classified into the following two types: 
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• General Purpose Application Software: Database Management Packages, Word Processors and Spreadsheets.
• Special Purpose Application Software: Accounting, Inventory, Production and Management.

BASICS OF OPERATING SYSTEM

A computer consists of various components such as input device, storage device, output device and CPU.  All these 
components together make a computer system. To utilise and manage this system properly, all its components should be 
managed properly.  The computer can understand only machine language and the user can communicate only by human 
understandable language. Therefore, there is a need to manage the basic hardware resources and provide an interface to 
users and their programs. This is done by special system software known as an Operating System (OS). It has bridged the gap 
between the user and the computer. 

Introducing Operating System

The operating system is a master program, which controls the functioning of the system. The main works of an operating 
system are: 

• Input/Output management
• Memory management
• File management

There are many operating systems in the Information Technology (IT) industry, but some of the popular operating systems 
are: UNIX, Linux, MS-DOS, Windows 95/98, Windows NT, Windows 2000 and Windows XP, etc.  

Operating System, an Interface between user and Hardware 

The User Interface 

The user interface can be defined as the way the user tells the computer what to do and how the computer displays 
information and options to the user. 

The two types of user interfaces are: 

• The Character User Interface (CUI): A text-based interface or Command Line Interface (CLI) means typing in all the
commands. Commands / instruction are given to computer in the form of characters.  If there is a typing mistake, you
need to backspace to the error, which erases what you already typed.

• The Graphical User Interface (GUI): Uses pictures. It is more user friendly.

Open Source Operating System 

Open source refers to a program or software in which the source code (the form of the program when a programmer writes a 
program in a particular programming language) is available to the general public for use and/or modification from its original 
design free of charge. Open source code is typically created as a collaborative effort in which programmers improve upon the 
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code and share the changes within the community. The basics behind the Open Source Initiative is that when programmers 
can read, redistribute and modify the source code for a piece of software, the software evolves.   

EduBOSS

EduBOSS is an open source operating system developed by C-DAC to make the best distribution for educational purposes. 
This operating system localize into all 22 official Indian languages, benefits non-English speakers to reach technology that 
bridge digital divide in India. It contains educational applications that are useful for school students. 

OpenOffice 

Open-source software is software whose source code is published and made available to the public, enabling anyone to copy, 
modify and redistribute the source code without paying royalties or fees. OpenOffice is an open-source office productivity 
software suite whose main components are for word processing, spreadsheets, presentations, graphics, and databases. 
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2. INTERFACE OF EDUBOSS

What is “open source”? 

In brief, open source software is software which meets the following criteria: 

1. Unrestricted redistribution. Open source software can be redistributed either for free or at a profit.
2. Source code. The source code (i.e.“blueprints”) for the software must be made available.
3. Derivedworks. The source code can be used to produce derived works.

The OpenOffice  software is a freely available, full-featured office suite. 

What packages does Open Office come with? 

It includes the following components. 

Writer (word processor) 

Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other documents. 
You can insert graphics and objects from other components into Writer documents. Writer can export files to 
HTML, XHTML, XML, Adobe’s Portable Document Format (PDF), and several versions of Microsoft Word files. It 
also connects to your email client. 

Calc (spreadsheet) 

Calc has all of the advanced analysis, charting and decision-making features expected from a high-end 
spreadsheet. It includes over 300 functions for financial, statistical, and mathematical operations, among others. 
The Scenario Manager provides “what if” analyses. Calc generates 2-D and 3-D charts, which can be integrated 
into other OOo documents. You can also open and work with Microsoft Excel workbooks and save them in Excel 
format. Calc can export spreadsheets to Adobe’s PDF and to HTML. 

Impress (presentations) 

Impress provides all the common multimedia presentation tools, such as special effects, animation, and drawing 
tools. It is integrated with the advanced graphics capabilities of OOo’s Draw and Math components. Slideshows 
can be further enhanced with Fontwork’s special effects text, as well as sound and video clips. Impress is 
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compatible with Microsoft’s PowerPoint file format and can also save your work in numerous graphics formats, 
including Macromedia Flash (SWF). 

Draw (vector graphics) 

Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to 3-D artwork. Its 
Smart Connectors feature allows you to define your own connection points. You can use Draw to create drawings 
for use in any of OOo’s other components, and you can create your own clipart and add it to the Gallery. Draw 
can import graphics from many common formats and save them in over 20 formats including PNG, HTML, PDF, 
and Flash. 

Base (database) 

Base provides tools for day-to-day database work within a simple interface. It can create and edit forms, 
reports, queries, tables, views, and relations, so that managing a connected database is much the same as in 
other popular database applications. Base provides many new features, such as the ability to analyze and edit 
relationships from a diagram view. Base incorporates HSQLDB as its default relational database engine. It can 
also use dBASE, Microsoft Access, MySQL, or Oracle, or any ODBC- or JDBC-compliant database. Base also 
provides support for a subset of ANSI-92 SQL. 

Math (formula editor) 

Math is OOo’s formula or equation editor. You can use it to create complex equations that include symbols or 
characters not available in standard font sets. While it is most commonly used to create formulas in other 
documents, such as Writer and Impress files, Math can also work as a stand-alone tool. You can save formulas in 
the standard Mathematical Markup Language (MathML) format for inclusion in webpages and other documents not 
created by OOo. 

Logging In and Selecting a Desktop 

To start a normal login, just enter your username and password. 

System 

Performs a system action, such as shutting down the computer or starting different login actions 

Locking Your Screen 

To lock the screen, use the keyboard shortcut Ctrl+ Alt+L. 

Logging Out 

When you are finished using the computer, you can log out and leave the system running or restart or shut down 
the computer. If your system provides power management, you can also suspend the computer, making the next 
system start much faster than a complete boot. 

To log out and leave the system running, do one of the following: 
• Select System >Log Out....

Use the keyboard shortcut that is defined in the GNOME keyboard shortcuts. Usually, to log out with 
confirmation, this is Ctrl+Alt+Del. You may find some more pictures on the desktop with self-explanatory labels. 
These pictures are called icons. 

Desktop Components 

The main components of the desktop are the icons on the desktop and the panel at the top and bottom of the 
screen. 
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EduBOSS Desktop 

Desktop Icons 
The desktop has the following icons by default: 

Trash 
Contains files and folders that have been deleted 

Computer 
Displays information about hardware, network status, operating system, hard disks, common folders, and 
removable devices 

Home 
Displays the files and folders in the home folder. 

Panel 
The panel is a bar, typically located at the top and bottom of the screen. It is designed to provide information 
about running applications or the system and easy access to some applications. If you hold your pointer over an 
icon on the panel, a short description is displayed. 

Top Panel 
The top panel typically consists of the following items: 

Menu Bar 
The Menu bar is located across the top of the screen, just below the Title bar. When you choose one of the 
menus, a submenu drops down to show commands. 

• File contains commands that apply to the entire document such as Open, Save, and Export as PDF.
• Edit contains commands for editing the document such as Undo and Find & Replace. It also contains

commands to cut, copy and paste selected parts of your document.
• View contains commands for controlling the display of the document such as Zoom and Web Layout.
• Insert contains commands for inserting elements into your document such as Header, Footer, and

Picture.
• Format contains commands, such as Styles and Formatting and AutoFormat, for formatting the layout of

your document.
• Table shows all commands to insert and edit a table in a text document.
• Tools contains functions such as Spelling and Grammar, Customize, and Options.
• Window contains commands for the display window.
• Help contains links to the OpenOffice.org Help file, What’s This?, and information about the program.

The following icons by default appears in the right side of the top panel 
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Notification Area 
The notification icons like Update Manager, SCIM appears in the notification area. 

Clock 
The clock icon displays the current date and time. 

Volume Control 
The Volume Control icon is useful for controlling the speaker volume. 

Window Selector 

This icon when clicked displays the applications running on different windows. 

Bottom Panel 
The bottom panel consists of the following items: 

Show Desktop 
This icon appears at the left side of the bottom panel. Click that icon to hide all the windows and show the 
desktop. 

Window List 
The Window List is located next to the “Show Desktop” icon. By default, all started applications and open 
windows are displayed in the Window List, which allows you to access any application regardless of the currently 
active desktop. If you click a window title in the Window List, the application is moved to the foreground. If it is 
already in the foreground, clicking minimizes the application.  

Workspace Switcher 
By default, the right end of the bottom panel has an icon which shows your different desktops. These virtual 
desktops enable you to organize your work. If you use many programs simultaneously, you might want to run 
some programs in one desktop and other programs in the other desktop. To switch between desktops, click the 
desktop symbol in the panel. 

MANAGING/CUSTOMIZING FILES AND FOLDERS 

A file in computer terminology can be considered as the modern counterpart of paper documents which 
traditionally were kept in offices and libraries. The term file is used in computers for a block of information, or 
resource for storing information. Some files icons are shown below for your reference with filenames 
Bill_Gates.jpg, Thoughtsofpranav.txt. 

Files can be managed based on their location on the storage device. Files are grouped into hierarchical folders or 
directories to make them more manageable.  
On Unix/Linux machines the hierarchy is: 
• The root directory (/)

• Directories (/usr "user" or /dev "device") 
• Sub-directories (/usr/local) 

• Files: data, devices, links, etc. (/usr/local/readme.txt or /dev/hda1, which is 
the hard disk device) 

In DOS/Windows the hierarchy (along with examples): 
• Drive (C:)

• Directory/Folder (C:\My Documents) 
• Sub-directory/Sub-folder (C:\My Documents\My Pictures) 

• File (C:\My Documents\My Pictures\VacationPhoto.jpg) 
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Commands that are used to manage (copy or move) the files to and from other directories on the varying 
platforms are listed here: 

• Unix/Linux: cp, mv
• DOS: copy, move
• Windows: the Cut/Copy/Paste commands in the Edit menu of Explorer

FILE OPERATIONS 

In EduBOSS, the Nautilus is a file manager. The 
following sections cover using Nautilus for file 
management.  

Moving a File or Folder 

You can move a file or folder by dragging it with 
the mouse, or with the cut and paste commands. 
The following sections describe these two 
methods. 
Drag to the New Location 
To drag a file or folder to a new location, 
perform the following steps: 

1. Open two file manager windows:
a. The window containing the item you want to move.
b. The window you want to move it to, or the window containing the folder you want to move it to.

2. Drag the file or folder that you want to move to the new location. If the new location is a window, drop
it anywhere in the window. If the new location is a folder icon, drop the item you are dragging on the
folder.

To move the file or folder to a folder that is one level below the current location; do not open a new window. 
Instead, drag the file or folder to the new location in the same window. 

Cut and Paste to the new location 
You can cut a file or folder and paste the file or folder into another folder, as follows: 

1. Select the file or folder that you want to move, then choose Edit→Cut.
2. Open the folder to which you want to move the file or folder, then choose Edit > Paste.

Copying a File or Folder 
You can copy a file or folder by dragging it with the mouse, or with the copy and paste commands. The following 
sections describe these two methods. 
Drag to the New Location 
To copy a file or folder, perform the following steps: 

1. Open two file manager windows:
The window containing the item you want to move. 
• The window you want to move it to, or the window containing the folder you want to move it to.

2. Drag the file or folder that you want to move to the new location. If the new location is a window, drop
it anywhere in the window. If the new location is a folder icon, drop the item you are dragging on the
folder.

To copy the file or folder to a folder that is one level below the current location, do not open a new window. 
Instead, grab the file or folder, then press and hold Ctrl. Drag the file or folder to the new location in the same 
window. 
Copy and Paste to the New Location 
You can copy a file or folder and paste the file or folder into another folder, as follows: 

20



1. Select the file or folder that you want to copy, then choose Edit→Copy.
2. Open the folder to which you want to copy the file or folder, then choose Edit > Paste.

Duplicating a File or Folder 

To create a copy of a file or folder in the current folder, perform the following steps: 
1. Select the file or folder that you want to duplicate.
2. Choose Edit >Duplicate.

A copy of the file or folder appears in the current folder. 

Creating a Folder 

To create a folder, perform the following steps: 
1. Open the folder where you want to create the new folder.
2. Choose File >Create Folder.

Alternatively, right click on the background of the window, then choose “Create Folder”. 
An untitled folder is added to the location. The name of the folder is selected. 

3. Type a name for the folder, then press Enter.

Renaming a File or Folder 

To rename a file or folder perform the following steps: 
1. Select the file or folder that you want to rename.
2. Choose Edit > Rename. Alternatively, right click on the file or folder, then choose “Rename...”.

The name of the file or folder is selected. 
3. Type a new name for the file or folder, then press Enter.

Moving a File or Folder to Trash 

To move a file or folder to Trash, perform the following steps: 
1. Select the file or folder that you want to move to Trash.
2. Choose Edit >Move to Trash.

Alternatively, right click on the file or folder, then choose “Move to Trash”. 
Alternatively, you can drag the file or folder to the Trash object on the desktop. 
When you move a file or folder from a removable media to Trash, the file or folder is stored in a Trash location 
on the removable media. To remove the file or folder permanently from the removable media, you must empty 
Trash. 

Deleting a File or Folder 

When you delete a file or folder, the file or folder is not moved to Trash, but is deleted from your file system 
immediately. The “Delete” menu item is only available if you select the 
“Include a Delete command that bypasses Trash” option in the Edit > Preferences dialog 
To delete a file or folder perform the following steps: 
1. Select the file or folder that you want to delete.
2. Choose Edit > Delete. Alternatively, right click on the file or folder, then choose
“Delete”. 

Alternatively, select the file or folder you want to delete, and press Shift+Del 
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3. WORD PROCESSORS
Introduction 

When you write an article or do your homework, what happens when you make a mistake, or you want to make 
some changes in the handwritten assignment?  

How do you create documents which are typewritten (like this one), but also have a certain size, shape and 
appearance (called formatting)? Some such formats could be bold lettering (standing out, darker than the rest of 
the text), italics (tilted to the right), etc.)!  What about pictures and diagrams that are inserted along with the 
text? How do you save them in a document, so you can share it with others (via email), print multiple copies, 
etc.?  

Word processors help us deal effectively with most of such issues. Let us understand how word processors have 
an edge over using the traditional paper and pen. Using word processors, you can create and use a Word 
document. Word processors provide flexibility, ease, neatness and speed. You can use it for writing documents 
such as, articles, letter, resume, report, poem and also making posters.  

Applications 

To sum up, a word processor can help you to: 

• Correct any spelling mistakes made and also prompt you when you make spelling error.
• Insert or overwrite a word or sentence or paragraph, anywhere in a Word document. This helps to

maintain the neatness of the document. This task is called editing the document.
• Print a document created by you and also store it for future use, without worrying about of it getting

misplaced/ fading. You can also print multiple copies of the document using a single command.
• Change the appearance of different portions of a document, by changing the size of the words, make

them bold or italic or underlined etc.
• Insert, headers and footers and page numbers (which increment automatically, if you so desire!).
• Present information in a tabular form as a part of the document.
• Insert pictures, and images into a document.

Some of the most popular Word Processing software are: 

• OpenOffice – Write (desk top based)
• MS-Word (desk top based)
• Google Documents(Internet based)
• Notepad(limited features)

Getting started 

Though you can choose any of the above listed software to start creating documents, it is preferable that you 
start learning word processing by using either the OpenOffice.org Writer or Microsoft Word. Make sure that this 
software is already installed in your computer. You can start using MS-Word software (any other software too 
would have almost similar steps), by performing any one of the following steps: 

• Double click on a shortcut key of the OpenOffice.org Writer icon.
OR

• Click Start > All Programs > OpenOffice.org 3.4 > OpenOffice.org Writer.
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If you are using any other word processor, the steps to start that word processor would be almost identical to 
what is given above. 

Components of Word 

Once you start OpenOffice.org Writer, the screen displayed in the figure below appears. The components of the 
screen displayed are as shown in the figure below. 

Opening or Creating a Document 

To begin with, let us create a simple document. Before creating the document, create a folder “D:\IT Class 
IX\WP_Practice” where you shall store all the documents that you create. 

Start the word processor. Write the following paragraph in the work area of your screen. 

Saving a Document 

Till now this paragraph that you have written is present in the internal memory of the computer, which is also 
called RAM (Random Access Memory). You need to save this document as a file on the hard disk of your 
computer. You can do so by doing the following steps: 

1. Select File→Save As…. (Or use keyboard shortcut, CTRL+S)
2. A Save As dialog box appears.
3. Choose the directory (drive and folder) by clicking on the one that you want in the list shown on the left

hand side. You will see the path on the D:\IT Class IX\WP_Practice displayed as you select the path.
4. Enter the name which you would like to give to this document in the File name box. For example, you

can give the name Listening to this file.
5. Click Save.

Listening is an art. God gave us two ears and one mouth, so that we speak less and listen more. Only 
by listening carefully can we understand what the other person is saying and the meaning behind the 
words being spoken. This helps us understand the facts and opinions of the other person. This also 
helps us to improve the quality of the questions we can ask the other person.  
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Now this word document would be saved in OpenOffice.org Writer with the name Listening.odt, in the directory 
specified by you. The first part of the filename- Listening-is the name you gave to this file and .odt is the 
extension name for any document created under OpenOffice.org Writer. 

Closing a Document 

You can close this document by following one of the following steps: 
• Click on the cross symbol “X”, that you see on the top right hand corner of the screen.

OR 
• Click File→Close.

Open an existing document 

If you want to make changes, for example, add a paragraph or some words in a document created earlier? What 
do you do? You will now open the file saved in earlier (D:\IT Class IX\WP_Practice \Listening.odt), edit it and then 
save it under a different file name. To begin, start the word processor. 

You can open a document only if it has been created earlier and saved on the hard disk / any other storage 
device. To re-open Listening.odt, do the following: 

1. Select File > Open. An Open dialog box appears.
2. Select the drive and folder, select filename and click the Open button. The saved document opens.

Edit a document 

After you open Listening.odt you can make changes to it, by adding another paragraph, or modifying any words 
or sentences which you had already written. Add one more paragraph in this document on” The Art of Listening”. 
You can add material on your own or use the follow paragraph: 

When we listen to another person, do not start judging what the other person is saying. Just listen and 
seek to understand the other person. This will help us to listen and seek to understand the point of 
view of the other person, without trying to judge whether you agree / disagree with what the other 
person is saying. By doing this you will become a more effective listener. 

Save the file with a different name 

Do remember that having made further changes; you need to save the changes by saving this modified document 
once again. You can save it with the same name Listening.odt, in which case the older file saved earlier will get 
overwritten by the changes which you made. Alternatively, you may like to keep the earlier file Listening.odt as 
it is, and save the modified document using a new file name, e.g. Listening2.odt. 

To save it with a different name, use the following steps: 

1. Select File→Save As….
2. A Save As dialog box appears. Choose the directory (drive and folder) by clicking on the one that you

want in the list shown on the left hand side. You will see the path on the D:\IT Class IX\WP_Practice
displayed as you select the path.

3. Enter the file name which you would like to give to this document. For example, you may name this file
Listening2.odt.

4. Select File→Save.

To practice once again what you have learnt, repeat the above three steps by opening any other existing 
document in your computer, making changes to the contents of that file and saving this file with another name. 
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To practice once again what you have learnt, repeat the above three steps by opening any other existing 
document in your computer, making changes to the contents of that file and saving this file with another name. 

Elements of the User Interface 

By now you would have observed that word processing software has very simple interface using dropdown menus. 
Most of the commonly used functions have a graphical symbol or icon. This kind of user interface is called 
Graphical User Interface or GUI (commonly pronounced “gooey”). GUI is a type of user interface that allows 
users to interact with electronic devices using images rather than text commands. 

Now, you will take a short tour of the different dropdown menus and some of the options under each dropdown 
menu. 

User Interface 

As shown in the figure above, the Ribbon has nine dropdown menus; namely, File , Edit, View, Insert, Format, 
Table, Tools, Windows and Help. Each dropdown menu further has submenus and commands; some commands 
are made available using toolbars. Some common operations under the main menu items are: 

1. File: Create, Open, Close, Save, Print files etc.
2. Edit: Cut, Copy, Paste, Undo, Redo, find & Replace, Record changes (review) etc.
3. View: Layouts, Ruler, enable or disable toolbars, hide/show non printing characters etc.
4. Insert: Breaks, Comments, Header, Footer, Table, Picture, Objects etc.
5. Format: Character and Paragraph formatting, Bullets and Numbering, Alignment, Change case, Grouping

objects etc.
6. Table: All Table & Cell operations (Insert, Delete, Select, Merge, Split. Borders), Formula, etc.
7. Tools: Spelling and Grammar, Mail Merge, Foot Notes, End Notes, Macros, etc.
8. Window: Close and Open new window.
9. Help: Use Help and check Product Updates.

Toolbars 

OpenOffice.org Writer displays Standard, Formatting, Bullets 
& Numbering and Find toolbars by default. If you want to add 
additional toolbars, do the following: 

1. Select View > Toolbars.
2. Notice the items checked in the list. If you want to

include Insert toolbar, select Insert from the Toolbars
list. Notice the Insert toolbar displayed; by default
toolbars float. To “fix” the toolbar, drag and drop it
near the main menu.

3. To close a toolbar, select the small arrow at the end
of a toolbar and select Close Toolbar.
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Print Preview 

Print Preview enables you to see what 
the document will look like when it is 
printed. You can Print Preview a 
document by selecting: 

File > Page Preview. 

Based on how you want the final printout 
to look, you can adjust the Margins, 
Orientation etc. A sample Print Preview 
of a page is shown in the adjacent figure. 

Print a document 

A copy of a saved document is accessible 
on the computer using a Word Processor. 
However, after is the document is 
completed, it needs to be printed to be 
read by others who are not using a computer. 

Note: In IT jargon, a document saved on the computer is called a Soft Copy and one that is printed is called Hard 
Copy. 

Open a new document and write the following text. 

Integrity is the integration of outward actions and inner values. A person of integrity is the same on the outside 
and on the inside. Such an individual can be trusted because he or she never veers from inner values, even 
when it might be expeditious to do so. A leader must have the trust of followers and therefore must display 
integrity. 

You will now take a print out of this document. Make sure that there is a printer connected with your computer 
and has paper in it. Do the following: 

1. Click File > Print. A Print dialog box appears (figure adjacent). There are many settings available in this
dialog box, which you can use, as required. Make settings as per the following:
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• Range and Copies: You can select what you want to print:

o All Pages: Whole document
o Pages: Specify the selected page

numbers that need to be printed.
For example, 2-6 means, print
page numbers 2, 3, 4, 5 and 6 
while1,3 means, print page
numbers 1 and 3.

• Number of Copies: You can select the
number of copies of the document to be
printed.

o Properties: If you click on the
Properties button, a Printer
Document Properties dialog box
appears (figure above), with many
more options which can be set.
You will learn about them later (in
advanced levels).

2. Click OK to print the document.

Close Word 

To close word, click on the Close control button on the Title bar (cross symbol “X”). 
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4. SELECTING AND EDITING TEXT
Selecting text using mouse 

Create a document with the sample text given below. 

To select the text “Good Manners”, do the following: 

• Move your cursor , so that it is on or just before the capital G at the beginning of “Good”.

• Press and hold down the left button of your mouse, then drag the cursor , to the right, going over
the words “Good Manners”, and then release the left mouse button. The text appears with a shaded
background and is highlighted indicating that these words have been selected.

Note: 

• To select just a single word, you can just double click on it.
• To select a line of text, either select the line by using click and drag of mouse or move the mouse to the

left margin of your document, point to the line and click.
• To select a sentence, place the mouse pointer on the sentence, press the

<Ctrl> key and click.
• To select a paragraph, place the mouse pointer on the paragraph and click

thrice.
• To select a page, press <Ctrl> and <G> keys. A Find and Replace dialog

box appears with the Go To tab selected. Type the number of the page you
want to delete, and click the Close button. Now press the <F8> key and
then press <Ctrl> and <G> keys again. When the Find and Replace dialog
box appears, type the next page number and press Enter. The entire page
is selected.

Copying text 

You can copy text from the document to a different position in the same document 
or to a new document. The original text is not altered. 

To copy the first point “Not interrupting others while they are talking;” and paste it 
at the end of the last line, follow the steps given below: 

Note: 

Copy means to select text and then copy that text onto your “clipboard”. The 
“clipboard” is a temporary short-term data storage area in your computer where 

Good Manners 
Some good manners to keep in mind are: 

- Not interrupting others while they are talking; 
- Not carrying on side conversations while someone is talking; 
- Considering other’s feelings and concerns when making decisions or comments; 
- Being respectful of the instructor and classmates; your peers and superiors at the workplace,` 
- Avoiding arguments and disagreements; 
- Providing assistance when asked; 
- Using terms such as “please” and “thank you.” 
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the text is temporarily placed. 

Paste means to place the text that is on the “clipboard” into your document. 

To copy the first point “Not interrupting others while they are talking;” and paste it at the end of the last line, 
follow the steps given below: 

1. Select the text that is to be copied.
2. Right-click the mouse anywhere on the selected text. A pop-up menu appears (figure adjacent). Click

Copy. The menu goes away but the text has been copied onto the clipboard.
3. Click at the end of the last line in the document and press Enter. The cursor moves down to the next

line.
4. Right-click, then click Paste. The selected sentence is copied below the last sentence.

Notice that the original sentence is still at the same place, it has been duplicated at the end of the last 
sentence. 

Cut and Paste 

There is a minor but very important difference between “Copy and Paste” and “Cut and Paste.” 

• In “Copy and Paste” the original set of text remains where it was and it is also pasted to another place in
the document.

• In “Cut and Paste” the original set of text gets deleted and it pasted to another place in the document.

Note: Cut means to select text and then copy that text onto your “clipboard”. 

You can now try the “Cut and Paste” feature by cutting the line “Avoiding arguments and disagreements”, and 
pasting it as the first line of your document. To do so, use the following steps: 

1. Select the text that is to be copied. (You have learnt to select text in Exercise 4.)
2. Right-click the mouse anywhere on the selected text. A pop-up menu appears. Click Cut. The menu goes

away.
3. Click at the beginning of the first line in the document and press Enter.
4. Right-click, then click Paste. The selected sentence is copied below the last sentence.

Notice that the original sentence has been deleted.  

Moving text 

There is a minor but very important difference between “Copy and Paste” and “Cut and Paste.” 

• In “Copy and Paste” the original set of text remains where it was and it is also pasted to another place in
the document.

• In “Cut and Paste” the original set of text gets deleted and it pasted to another place in the document.

You can now try the “Cut and Paste” feature by cutting the line “Avoiding arguments and disagreements”, and 
pasting it as the first line of your document. To do so, use the following steps: 

1. Select the text that is to be copied.
2. Right-click the mouse anywhere on the selected text. A pop-up menu appears.
3. Click Cut. The menu goes away.
4. Click at the beginning of the first line in the document and press Enter.
5. Right-click, then click Paste. The selected sentence is copied below the last sentence.
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Notice that the original sentence has been deleted. Similarly, you can cut a line of text, a sentence, a paragraph 
or even a page! 

Deleting text 

You use the Backspace (one character to the left – in front - of the pointer) and Delete (one character to the 
right – behind- of the pointer) keys to delete single characters in the document. 
Similarly, to delete a line of text, a sentence, a paragraph or even a page, first select it and the press the 
Delete key. 

Undo and Redo 

When you have made a change and want the original back, you use the Undo feature of a word processor 

(reverse change). Whereas using the Redo feature, you repeat the last action(s) (repeat change). You use Undo 

and Redo icons on the Standard toolbar (figure adjacent – the buttons are not highlighted till 

you enter text) or shortcut keys, for these features.  
To undo an action you can either click on the Undo button on the Standard toolbar or press the <Ctrl> and <Z> 
keys together. To undo several actions at the same time, click on the arrow next to Undo, select the actions 
from the list displayed and then click the list. All selected actions will be reversed. 

To redo an action that you had un-did, you can either click on the Redo button on the Standard toolbar or press 
<Ctrl> and <Y> keys together.  

Check Spellings 

The word processor also helps you create flawless documents by checking the spellings. In case you have typed 
wrong spellings, the processor can highlight the words that have been spelt wrongly. 

To learn to use the Spelling and Grammar checker, do the following: 

1. Open a new document in word processor and type in the following paragraph. You would notice that
some words given in this paragraph have spelling mistakes. Type the paragraph along with these
mistakes.

We spend years learning hwo to read and write but not even a class or two on listening! People think that 
listening is nattural and that they do not have to learn it. It’s like breathing. 
This is sad since listening is primarily responsible for the many problems we have with each other. We speak at 
an average of 150 words per minute but our mind with its billions of cells can process almost a thoujand words 
per minute. Managing this excess brain capicity is the clue to effective listening. 

2. You would notice that the words which have spelling mistakes are
highlighted with a wavy red line (for example: hwo). This is done
automatically by the word processor.

I. Select Tools > Spelling and Grammar…(F7) (figure 
adjacent). 

II. The Spelling and Grammar dialog box appears. You can
see that it is suggesting that the correct spelling is 
“how”. You can click on the suggestion “how” and the 
spellings will be automatically corrected and the dialog 
box will proceed to show you the next spelling mistake and give you multiple options through 
the dialog box. You can choose the applicable suggestion or option and move ahead. 
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Note: Though the word processor may suggest changes, you need to use your own 
discretion whether to change / not to change the spelling; or, which spelling to choose 
from the list provided. Also, the word processor automatically runs through your 
entire document suggesting corrections for spelling and grammar. If you have selected 
some text, it will first check the selected text and then prompt you for checking the 
rest of the document. 

A word processor also provides another way to change a spelling mistake. The steps 
are listed below: 

I. Position the cursor on any part of the misspelt word (the word 
with a wavy red line below it). 

II. Right-click the mouse.
III. A pop-up menu box appears (figure adjacent).
IV. You can select the correct spelling option on the top (given as

“natural) and the spelling will be corrected automatically in the text.

Go ahead and correct the spelling mistakes in the paragraph. 

Standard dictionary includes commonly used words that are usually sufficient. However when you use terms or 
words that are not found in the dictionary, word processor displays those as misspelled words. In such cases you 
can add those new words to the dictionary. To add a word to the dictionary, do the following: 

1. Select the word that you want to add to the dictionary (highlighted in Red).
2. Select Add dropdown menu (in the Spelling and Grammar dialog box and click Standard.dic.
3. Now the word is added to the dictionary.
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5. FORMATTING A DOCUMENT
Formatting 

Formatting literally means the way in which something is presented, organized or arranged, generally to give it a 
better appearance. In a word processor, formatting involves using Spell and Grammar checking, Fonts, Paragraph 
styles, Bullets and Numbering, Line spacing, Borders and Shading, Columns, Tab positions, Indentations, Margins, 
etc. Let us now look at some of the formatting features. 

Font 

Font refers to the style of writing i.e. how the characters look in a document. The look of characters can be 
changed using the options in the Font group under the Home tab. Create the document shown below.  

You can change the font in two ways, using the dropdown menu from the toolbar and using the shortcut menu. 

Using the Icons from the toolbar 

1. Select the text “This is Cambria font.”
2. Select the Font Name dropdown menu. A

screen displaying a list of Font types appears
(figure adjacent).

3. Scroll and click on the Cambria font. The
font of the selected text will change to
Cambria.

Now go ahead and follow the same steps for 
changing the font style of others sentences, to what 
is written in the text. The final output should look 
like the figure below. 

Using Short cut menu and the dialog box 

We will restart with the original document above. 

1. Select the text “This is Cambria font” and right click
the mouse button. A short cut menu appears.

2. Click on the option Font. A list of fonts is displayed.

This is Cambria font. 
This is Times New Roman font. 
This is Bookman Old Style font. 
This is Courier New font.
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3. Choose the font Cambria from the given font list.

Now go ahead and follow the same steps for changing the font style of others sentences, to what is written in 
the text. 

You can also change font by right-clicking and selecting Character. The Character dialog box appears (figure 
below). 

Create the document as shown in left side of the figure below. Then change the font size of each of the 
sentences, as shown in the right side of the figure below. 

The steps to do this are similar to what you followed for changing the font style. 
The only difference is that now you need to use the option of changing the font size, instead of the font style. 

Text Alignment 

Now that we have seen some different capabilities of a word processor, let us see how this can be useful. A 
common usage or example of a document is a letter. We can use a Word Processor to type a letter in the proper 
form. You need to write the letter given below in a document. 

1. Now save the above document in the computer.
2. The date in the above letter is on the right hand side. This is called Right Alignment of a text.
3. Similarly, the subject line in the above letter is in the middle. This is called Centre Alignment of the

text.
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On the Formatting toolbar you would notice the set of icons (figure adjacent) 

o To Right Align the date, select the date. Then click the icon for Align Right. Similarly, you can
Centre Align the Subject line in the above letter.

Do remember to save the above letter with the changes made! 

Character formatting 

As a student you have done that by underlining text in your textbooks. Similarly, using a word processor you can 
select and make parts of the documents bold or italics or underlined. This is also a part of “formatting” a 
document. 

To format a document, do the following: 

1. Open a new document in word processor and type in the following paragraph:

What is A Team? 
“A team is a number of persons associated together in work or activity: as a group on one side (as in 
football or debate).” A Team is a group of people working together „or‟ come together as a team to 
achieve a common shared goal. In other words, when one person cannot complete a job alone and 
several individuals must cooperate to fulfill a mission, you need a team. The better the cooperation, 
communication, and coordination among team members, the more efficient the team. 
“Individually, we are one drop. Together, we are an ocean.” 

Tagore Public School 
Ambala Cantt 

5th January 2012 
M/s New Star Sports Company 

Kalkaji 
New Delhi -1100 

Sub: Order for Sports Materials. 
Dear Sir, 

Kindly send the following Sports material at the above address through transport with 
proper cash bill. 

1. Foot Ball (10 Nos).
2. Cricket Balls. (20 Nos).
3. Tennis Balls (20 Nos).
4. Cricket Bats (10 Nos).

All the items should be in good condition and packed properly. Any damage to these 
items during transportation will be your responsibility. The items should reach the 
school within 10 days after the receipt of the letter; otherwise the order shall stand 
cancelled. 

Thanking you 

Yours sincerely 
Nitish 
(Head Boy) 
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2. Now to make this paragraph to look better, you may need to format it like the paragraph shown below. 
You will notice that some words of this paragraph are in bold, some are in Italics and some are 
underlined. 

What is A Team? 
“A team is a number of persons associated together in work or activity: as a group on one side (as in 
football or debate).” A Team is a group of people working together „or‟ come together as a team to 
achieve a common shared goal. In other words, when one person cannot complete a job alone and 
several individuals must cooperate to fulfill a mission, you need a team. The better the cooperation, 
communication, and coordination among team members, the more efficient the team. 
“Individually, we are one drop. Together, we are an ocean.” 

Selecting text 

To make the text “What is A Team?” bold, you need to first select this text. Use the following steps to do so: 

1. Move your cursor, so that it is on or just before the capital W at the beginning of “What”. 
2. Press and hold down the left button of your mouse, then drag the cursor, to the right, going over the 

words “What is a Team?”, and then release the left mouse button. 
3. What is a Team? will appear. The shaded background and highlighted letters indicates that these words 

have been selected. 

Note: To select just a single word, you need to double click on it. 

 
Formatting Toolbar  

Bold: Click on the Alphabet B in the Font group, and you will see that the words “What is A Team?” is now bold. 
Go ahead use the same steps and make the required words bold. 

Underline: The steps for underlining, any word or a group of words is exactly the same as foe Bold, except that 
after selecting the text, instead of clicking B, you need to click U in the Font group. 

Italics: The steps for italicising, any word or a group of words is exactly the same as the above two, except that 
after selecting the text, you need to click I in the Font group. 

If you are creating a textbook with scientific content, you need to use special formatting for some characters. 
Character formatting can be applied to a single character or word. Do the following: 

a. Open a new document in word processor and type the following paragraph: 

Water is a chemical substance with the chemical formula H2O. A water molecule contains one oxygen 
and two hydrogen atoms connected by covalent bonds. Water is a liquid at ambient conditions, but it 
often co-exists on Earth with its solid state, ice, and gaseous state (water vapor or steam). Water also 
exists in a liquid crystal state near hydrophilic surfaces. The density of water is 1,000 kg/m3. 

Now to make changes, you may need to format the characters as shown below. You will notice that some words 
of this paragraph are in bold, some are in Italics, some are underlined, some are in color and some are changed 
in its position (superscript & subscript). 
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a. In order to apply formatting to the contents in
the document you must select the concerned
word or group of words and select Character…
from the Format dropdown menu.

Use the following options to make changes to a 
character or word: 

Font tab: 

Font: After selecting the text you need to select the 
Font from Font Name list.  

Size: After selecting the text you need to select the Size 
from Font Size list. 

Font Effects tab: 

Font Color: Use this option to change the color of the 
text. You can choose the text color by clicking on the 
Font Color dropdown arrow. 

Strikethrough: Choose a style from Strikethrough 
dropdown menu to make a strikethrough the middle of 
the selected text.  

Position tab: 

Subscript: After selecting the text you need to select 
the position Subscript to make the selected text lower 
than the normal text position.  

Superscript: After selecting the text you need to select 
the Position Superscript to make the selected text 
higher than the normal text position. 

You can also use the icons on the formatting toolbar to 
subscript or superscript text.  

Increase Font: After selecting the text you need to click 
the icon in the formatting toolbar to make the font size 
larger than the current font size by the specified point.  

Reduce Font: After selecting the text you need to click 
the icon in the formatting toolbar to make the font size smaller than the current font size by the specified point. 
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Text Highlight Color: Use this option to set or change the background color of the text. You can choose the 
background color by clicking on the down arrow on the icon. 

Font Color: Use this option to change the color of the text. You can choose the text color by clicking on the 
down arrow on the icon. 

Clear Formatting: Clear formatting is 
used to clear the character formatting 
(such as Bold, Italics ,Underline, font 
face & size, superscript & subscript 
etc.) of the selected text. To remove 
the character formatting, select Clear 
Formatting from Apply Style dropdown 
menu in Formatting toolbar (figure above). 

Change Case: Word processor helps us to 
change the text case to capital letters or 
small letters. You can also capitalize each 
word in the sentence and capitalize the 
starting word of a sentence. To change 
case, select the text, right-click and select 
options as applicable (figure adjacent). 

Sentence Case: On selecting this option from the dropdown list, the first character in the first word of the 
selected sentence will be converted to Capital Letter (Uppercase).  

Lowercase: On selecting this option from the dropdown list, the 
selected text will be converted to Small Letters (Lowercase).  

UPPERCASE: On selecting this option from the dropdown list, the 
selected text will be converted to Capital Letters (UPPERCASE).  

Capitalize Each Word: On selecting this option from the dropdown 
list, the first character in all the words of the selected sentence will 
be converted to Capital Letter (Uppercase).  

tOGGLE cASE: On selecting this option from the dropdown list, the 
small letters in the selected text will be converted into capital letters 
and capital letters will be converted into small letters.  

You may like to enter some more text from your English text book and practice making words bold, italics or 
underlined, or changing the text colors etc. 

Find and Replace 

Suppose you have created Social Science notes using word processor and you notice that at some places in the 
document the word Delhi has been misspelled as Dlehi. Now to correct it you need to find where the error has 
occurred and change/replace it with a new text. You can use the Find and Replace feature of word processor to 
easily do this task. Using this feature, you can automatically trace/find all the occurrences of a word or group of 
words and replace them with a new word or a group of words. 

Enter the following text in a new document and save the file with the name Global Warning. 
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What is Global Warning? 
Global warning is when the earth heats up (the temperature rises). Global warning happens when 
greenhouse gases (carbon dioxide, water vapor, nitrous oxide, and methane) trap heat and light from 
the sun in the earth‟s atmosphere, which increases the temperature. This hurts many people, animals, 
and plants. Many cannot take the change, so they die. Global warning is a very important issue for the 
survival of life on earth. 

In the above text you would notice that four words have been highlighted. You 
have entered the word “Warning” instead of “Warming.” You will now learn 
how to find the “warning” at each of the places it occurs in the document and 
replace the word with “warming”. Follow the steps given below: 

1. Select Edit dropdown menu and click Find & Replace… or press CTRL+F
keys together.

2. A Find and Replace dialog box appears (figure below).

3. To just find the word, click Find. Enter text you want to search in the Find what box. To find one such
word, or phrase, click Find Next. To find all occurrences of the word or phrase, click Find in , then click
Main Document.

4. To find and replace, click Replace. Enter text to find in Find what. Enter text to replace in Replace
with.

5. Choose the action to be taken by clicking on – Replace, Replace All, Find All buttons accordingly.

What is Global Warming? 
Global warming is when the earth heats up (the temperature rises). Global warming happens when 
greenhouse gases (carbon dioxide, water vapor, nitrous oxide, and methane) trap heat and light from 
the sun in the earth‟s atmosphere, which increases the temperature. This hurts many people, animals, 
and plants. Many cannot take the change, so they die. Global warming is a very important issue for the 
survival of life on earth. 

Note: 
You need to be careful while using Replace All. Replace All is a global function. It replaces the selected text 
with the specified text all over the document. There may be an instance where a word needs to be retained, but 
in a global replace, it gets over written. For example if in the text you had typed, there was a sentence “We 
must pay heed to the warning signals of nature.”, and you used a global replace (Replace All), the word warning 
would also be replaced as warming! 

Changing line spacing 

You may need to change the format document from single to double line spaced. This puts a space between each 
line of the text, making it much easier to read. This is the acceptable for many publications. To change the line 
spacing, 
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1. Select and highlight the text (you want to
change) in a document created earlier.

2. Select Format > Paragraph. The
Paragraphs dialog box appears with the
Indents & Spacing tab selected.

3. Select the appropriate option from the Line
spacing drop down. You can see the
resultant preview of how your text will look
on the right hand section of the dialog box.

4. Select OK. The selected text will have the
desired effect.

Bullets and Numbers 

Very often, you need to create a list of items. This 
can be neatly done by using the features described 
below:  

You need to create a document as given below in the box. 

Enter the above text in the document. Now do the following 
steps: 

1. Select the text of the group of first four statements
below the heading “Greeting a friend”.

2. Select Bullets On/Off from Formatting toolbar. You
will see that the bullets appear at the beginning of
each of the four sentences.

3. Also notice the Bullets and Numbering toolbar

appears. Select  icon from this toolbar to open the
Bullets and Numbering dialog box (figure adjacent).

Every interaction starts with some form of greeting. Given below are some statements we 
generally make whenever we greet someone. 
 

Greeting a friend: 
• Hi! How are you doing?
• Hey! It has been a long time since we last met!
• Hi! What are you doing now?
• Hey! How’s life?

Greeting an acquaintance: 
• Hello! How are you?
• Hello! How have you been?
• Good morning/afternoon/evening! All’s well?

Greeting a stranger: 
• Hello!
• Good morning/afternoon/evening!
• How do you do?
• My name is Aarti. May I know your name?
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4. Select the bullet style from the list displayed.

Repeat the above given step 1 and 2 with the other two 
headings. 

Now create another document and create a bulleted list of items you would pack, when you for a family holiday. 
Try numbering this list, with the Numbering icon. 

When is it better to use bullets than numbers? 

Use numbered lists when you're working with instructions to be done in a sequence i.e. steps to be followed, and 
the numbers suggest a hierarchy. The same applies when you refer to specific items by 
number. Numbered and unnumbered lists are more commonly used in scholarly 
publications. If numbers aren't essential (very necessary), use bullets, especially in 
business documents. 

When to capitalize the first letter in a bulleted item? 

In most cases, it is recommended that you start each bulleted item with a capital 
letter. Till now, you have capitalized only proper nouns and the first word of a 
complete sentence, so it almost seems wrong to capitalize single words and phrases. 
However, for the sake of a good presentation, you need to do it anyway. 

Add borders to a Page 

A border around text highlights the information and makes it look better. 
Word processors enable you to do that neatly for the entire document or part 
of it. 

Follow the steps given below to add a border to the complete page: 

1. Open a new document.
2. Select Format dropdown menu and select Page….
3. Page Style: Default dialog box appears. Select Borders tab.

o Select Set All Four Borders under Line Arrangement
o Select 1.00 pt from Style
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o Select a color from Color dropdown
4. Select OK.

Add borders to a paragraph or a text 

1. Type the following paragraph in a document.

Assertiveness is not the same as aggressiveness. Rather, it is the ability to clearly state what one expects so 
that there will be no misunderstandings. A leader must be assertive to get the desired results. Along with 
assertiveness comes the responsibility to clearly understand what followers expect from their leader. 
Many leaders have difficulty striking the right amount of assertiveness, according to a study in the February 
2007 issue of the Journal of Personality and Social Psychology, published by the APA (American Psychological 
Association). It seems that being under assertive or overassertive may be the most common weakness among 
aspiring leaders. 

2. Select Format dropdown menu and select Paragraph….
3. Paragraph dialog box appears.

o Select Set All Four Borders under Line Arrangement
o Select 1.00 pt from Style
o Select a color from Color dropdown

4. Click OK.

You can similarly create a border around a group of words, by selecting that group of words, and following the 
same steps as given above. An example is given below. 

A sense of humor is vital to relieve tension and boredom, as well as to defuse hostility. Effective 
leaders know how to use humor to energize followers. Humor is a form of power that provides some 
control over the work environment. And simply put, humor fosters good camaraderie. 

Shading 

Similar to borders, shading highlights desired parts of the text. The steps to apply shading are almost the same 
as that for applying borders. Do the following: 

1. Select the text to which the shade has to be applied.

2. Select Format dropdown menu and click Paragraph. The Paragraph dialog box appears. Select the
Background tab.
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3. There are two options in this box.  

• You can apply a solid color as the background. Select a color from As dropdown list. 
• You can use an image or clip art as the background. Select Graphic from the As dropdown list.  

Select browse to choose a picture, select Open and select OK to apply the picture as the 
background. 

 
 

Two sample shadings are shown below as examples. 

Assertiveness is not the same as aggressiveness. Rather, it is the ability to clearly state what one expects so 
that there will be no misunderstandings. A leader must be assertive to get the desired results. Along with 
assertiveness comes the responsibility to clearly understand what followers expect from their leader. 

 

Inserting Hyperlink 

Hyperlink refers to the link that attaches internal or external resource in a document. The external and internal 
resources can be a URL, a document file, or a picture file.  

For example, you want to create a project proposal, which should include text information, numeric figures, 
internet data, and diagrams. You have already collected all the information but on various locations of your hard 
drive, and now you have to present the project, as early as possible, in front of your Project Manager to discuss 
that proposal.  

Writer helps you to link all the data in a presentable manner. It includes an enhanced Hyperlink tool facility, 
which enables you to link the current document with the specified Internet sites, and the information available 
on another document generally. 

Writer provides several types of Hyperlinks, such as Hyperlink with Internet, with document, with mail and 
messages, and with new documents.  
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To insert Hyperlink with Internet, perform the following steps: 

1. Click the InsertHyperlink menu option to display the Hyperlink dialog box and enter an Internet site
address (URL), which you want to link with your document in the Target text box under Internet page. For
example, www.google.com

2. Specify other hyperlink information in the Further settings section.

The Hyperlink Dialog Box 

3. Click the Apply button to insert the hyperlink on the document.
4. Click the Close button to close the Hyperlink dialog box.

To insert Hyperlink with any document, perform the following steps: 

1. Click the InsertHyperlink menu option to display Hyperlink dialog box, as shown in the following figure:
2. Specify the path of the file, such as C:\New Folder, which you want to open.
3. Specify the name of the file, such as Sheet1 in the Target text box, the targeted document as per the

requirement.
4. Type the heading, such as Sales Figures of your link in Text box.
5. Click the Apply button to insert the hyperlink on the document.
6. Click the Close button to close the Hyperlink dialog box.

• Hyper link can be inserted through hyperlink toolbar, as ViewToolbarsHyperlink menu option, or

by clicking on hyper link icon  available on standard toolbar.

• To jump to a specific line in a text document, first enter a bookmark at that position using
InsertBookmark.

Inserting an image from a file 

When the image is available in a file stored on the computer, you can immediately insert it into the Writer 
document. Writer can import various vector (line drawing) and raster (bitmap) file formats. The most common 
are GIF, JPEG or JPG, PNG, and BMP. 

To insert a graphic (image) from a file: 
1. Place the cursor at the appropriate location in the document.
2. On the main menu, select Insert > Picture > From File.
3. On the Insert Picture dialog, navigate to the file to be inserted, select it, and click Open.

At any time, you can embed linked images into the main file. To do so: 

1. Open the document in Writer.
2. Choose Edit  Links from the menu bar.
3. The Edit Links dialog shows all the linked files. In the SOURCE FILE list, select the files you want to change

from linked to embedded.
4. Click the Break Link button.
5. Save the Writer document.
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Drop caps 

A drop cap is the first letter of a paragraph formatted as a large capital letter that can be several lines in height. 
This can be made part of a paragraph style, but the paragraph must contain at least as many lines as the height 
of the drop cap—shorter paragraphs, even if tagged with the style, won’t show a drop cap. 

1. Choose Format  Paragraph, or right-click and choose Paragraph or (for paragraph style) right-click and 
choose Edit Paragraph Style. 

2. On the Drop Caps tab, choose the number of characters to include in the drop caps (usually this is 1), the 
number of lines for the height of the drop cap, and any extra space to text. You may need to experiment to 
find the best settings. 

3. (Optional) Choose Drop Caps for the character style. See the next topic for more on the Drop Caps character 
style. 

4. Click OK when done. 

 

Creating and Formatting Table 

You can represent tabular data, consisting of rows and columns, using tables. To create and format a table, you 
need to perform the following tasks: 

• Create a new table. 
• Enter data in a table. 
• Format a table. 
• Make calculations on the data of a table. 

Creating a Table  

A table is a collection of rows and columns. It consists of boxes, called cells. A cell is basically an intersection of 
rows and columns. A group of cells arranged vertically is called a column. A group of cells arranged horizontally 
is called a row. 

For example, you have to present monthly productivity figures of an automobile company. There are two ways to 
present data, one is to present in the text format and the other is to present the data in the tabular form.  

Consider that the monthly productivity of XYZ automobile company is: 

• The production of model no. 001 is 500 in January, 600 in February, and 700 in March.  
• The production of model no. 007 is 400 in January, 250 in February, and 600 in March.  
• The production of model no. 009 is 300 in January, 200 in February, and 500 in March.  
• The production in March is much better than the other month. 

The following table shows the data of an automobile company:  
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Model No. January February March 
001 500 600 700 
007 400 250 600 
009 300 200 500 

Displaying the Quarterly data 

To create a new table, perform the following steps: 

1. Click TableInsertTable menu option to display the Insert Table dialog box:

The Insert Table Dialog Box 

2. Type 4 in the Columns text box and 3 in the Rows text box under the Size section.
3. Select the Border check box to apply border in the table.
4. Click the OK button to create a table.

Adding and Merging Rows and Columns 

In a table, data can be increased or decreased based on your requirement. For increased data, you have to add 
more rows in the existing table. For example, in a table you have provided information only for 3 months but the 
information will gradually increase for 12 months then in that case, you can increase the number of rows in a 
table.  

Adding Rows and Columns 

To add rows in a table, perform the following steps: 

1. Click the TableInsertRows menu option to display Insert Rows dialog box:

Insert Rows Dialog Box 

2. Enter the number of rows, such as 4, that you want to add in the Amount text box.
3. Select the After radio button under the Position section to specify that you want to add rows after the

existing rows in a table.
4. Click the OK button to add rows.

To insert columns in a table, perform the following steps: 

1. Select the TableInsert Columns menu option to display Insert Column dialog box:
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Insert Columns Dialog Box 
2. Enter the number of columns, such as 4, in the Amount text box.
3. Select the Before radio button under the Position section to specify that you want to add columns before

the existing columns in a table.
4. Click the OK button to add columns.

Merging Cells in a Table 

You can select adjacent cells and then merge into a single cell. To merge cells in a table, select adjacent cells of 
the table and then from the Table menu, select the Merge Cells option to merge the cells. 

Formatting a Table 

You can format a table using the Table toolbar. It enables you to format the background, table border, and 
border style. You can use variety of fonts, font style, effects, borders, and shading options over your table to 
present it in an effective manner. Writer provides pre-formatted table designs, which you can apply directly to 
create a designer table.  

To apply the preformatted styles in a table, perform the following steps: 

1. Click the TableAutoFormat menu option to display the AutoFormat dialog box:

Auto Format Dialog Box 
• Click on Auto Format button  in the Table toolbar to open AutoFormat dialog box. 

2. Select a formatting style, such as Gray from the Format list and the preview is displayed.
3. Click the Add button to add user defined table format in the Format list.
4. Click the More button to view the available formatting options.
5. Click the OK button to apply the auto format style in a table.
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6. INTRODUCTION TO PRESENTATIONS
In this chapter, you will learn about: 

• Introduction to presentation.
• Applications of presentations.
• Start a presentation.
• User Interface of a presentation software.
• Opening - Creating – Saving a presentation.
• Closing a presentation.
• Printing a presentation.

Introduction 

Imagine a scenario - you want to make a presentation on a particular topic to your class along with text, images, 
figures, drawings, etc., - how would you go about doing it? You could have a choice of using a blackboard, 
posters, whiteboard, pamphlets, chart-paper, hand-outs or overhead transparencies. 

Presentations made using presentation software provides an alternative to the older kind of visual aids. 
Presentation software can be used to present a formal display of information organized onto slides. A digital 
presentation is a useful method to show or explain a concept to an audience. A presentation program (also called 
a presentation graphics program) is actually a computer software package used to display information; normally 
in the form of a slide show. It typically includes three major functions:  

1. An editor that allows text to be inserted and formatted
2. A method for inserting and manipulating graphic images
3. A slide-show system to display the content.

Applications 

Presentations can be used for a variety of tasks. For example: 

• Creating slides to display information. Slides may contain text, pictures, shapes, sound and video. A
collection of slides is called a presentation.

• Present the information in an attractive manner.
• Show the presentation using a computer, or display it using a data projector or take paper printouts.

Why would you create a presentation vs. using a word processed document? It depends, but typically you would 
use a presentation under the following circumstances: 

• When you want a large group of people to view what you are talking about on a projected screen you
would use presentation software. But when you want to share information with a couple of people, you
might use a document. In other words, if the material is to be viewed by others in a meeting, you may
use presentation software. If it is to be viewed by the other readers on a screen or through print, use
documents.

• When you want to make the material more interesting with graphics, tables, pictures and other media,
you may use presentation software. Word processors have limited multi-media capabilities.

• When you have a lot of information that needs to be written down, use word processor documents. When
shorter point-wise information (like a summary) would be sufficient, you may use presentation software.

Some of the most popular presentation software are: MS-PowerPoint, Open Office – Impress and Google 
Documents 
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Introducing Impress 

OpenOffice.org Impress is an application which enables you to create presentations. Impress presentation can be 
used for classroom teaching, introducing a product to sell, or explaining an organizational structure. You can 
create impressive presentations having graphic and multimedia features using Impress.  

 The main features of Impress are: 

• Creating Vector Graphics: Provides various tools to create vector graphics. In vector graphics images
are generated from mathematical descriptions that determine the position, length, and direction of the
drawn lines.

• Creating Slides: Provides you large number of templates to create presentations having animation and
transition effects.

• Viewing Presentation: Provides various types of presentation views, such as Slide Sorter view and
Handout view.

• Publishing Presentation: Provides features to publish slides as handouts, or as HTML documents.

Before you begin with creating presentations, you will have to start the Impress application. For this, click 
StartProgramsOpenOffice.org 2.0 OpenOffice.org Impress. The following table lists the main 
components of Impress window: 

Item Description 
Menu Bar Displays several menu choices 
Title Bar Displays current presentation name 
Line and Filling 
Tool Bar 

Provides several formatting commands including Line, Line Style, Area, and 
Area Filling 

Help Provides tutorials to help you to learn Impress 
Placeholders Designates space that will be filled with title, text, or objects, such as 

organizational charts and tables 
Slide tabs Enables you to quickly navigate and edit the available slides 
Presentation Tool 
bar 

Enables you to manage the slides in a presentation 

Drawing Tool bar Enables insert and edit drawing object in presentation slides. 

The following figure shows the tool and component of Impress Window: 

Scroll bar

Slides tabs

Menu bar Title bar Line and Filling Toolbar

Task pane

Placeholders

Drawing 
toolbar

The Impress Window on Startup. 
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Creating Presentation  

A presentation may include text, graphic, audio, and video to increase the interest of the audience on that 
topic. In Impress, you can create a presentation in two ways:  

• Using wizard
• Without using wizard

 Using Wizard 

To create a presentation using wizard, perform the following steps: 

1. Select FileWizardsPresentation menu option to display the Presentation Wizard:

2. Ensure that Empty presentation radio button is selected and click the Next button. The Slide design page
appears:

3. Select the Presentation Backgrounds option from the drop down list box and select the Dark Blue with
Orange option from the list box under the Select a slide design section.

4. Click the Next button to display the Slide transition and Presentation type selection page:

5. Select the Wipe Up option from the Effect list under the Select a slide transition section.
6. Select the Speed option from the Speed list under the Select a slide transition section.
7. Select the Default radio button under the Select the presentation type section.
8. Click the Create button to create the presentation. The Untitled1- OpenOffice.org Impress window

appears.

Wizard prompts you for information about the presentation you want to create. The entire presentation is 
displayed in an outline form and you can create presentation on that outline. 

Without Using Wizard 

When you want to create a presentation with your own settings and properties, perform the following steps: 
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1. Select FileNewTemplates and documents, to display the Templates and Documents - Templates
dialog box:

2. Select Introducing a New Product from the Title list.
3. Click the Open button to create a new presentation. The following window appears:

Editing Slide Text 

If you want to make some changes in the text slide, then you can edit the text.  Before editing text you need to 
select the text. For this, you can perform the following methods: 

Selection  
Method 

Technique 

Drag This method is ideal for small selections, such as individual character. In this 
technique, press the left mouse button at the first character of text you want to 
select, drag the mouse pointer to the last character of text, and release the 
mouse button. 

Select a word Point anywhere inside the word and double-click the word. 
Select a bullet Point anywhere inside the bullet item and click the left mouse button. 
Deselect Click any where outside the selected text. 

Editing Master View 

Impress enables you to create master view, where you can add the elements which should appear on all of the 
slides in your presentation. 

50



• Select ViewMasterSlide Master, to switch to slide master view, where you can add elements.
• Select ViewMasterNotes Master, to display the notes master, where you can set the default

formatting for notes.

Saving Presentation  

Impress provides the facility to save your presentation for future use. To save a new file, perform the following 
steps: 

1. Select FileSave menu option, to open Save As dialog box.
2. Select the location, such as C:\New Folder, where you want to save your presentation by selecting a folder

from the Save In drop-down list.
3. Enter a file name, such as Mypresentation in the File Name text box.
4. Click the Save button to save the file.

• After putting any change or modification in old or exiting presentation you can save the modifications

by clicking the Save button . Or, pressing short key Ctrl+S.

To save an existing document at different location or to change the location of exiting file, perform the 
following steps: 

1. Open an existing file.
2. Select FileSave As menu option to display Save As dialog box.
3. Select the location, such as C:\New Folder where you want to save your presentation.
4. Click the Save button to create another copy of same file at different location.

Opening an Existing Presentation 

When you save your presentation, it is stored as a file at some particular location on the disk. When you open 
that file, Impress places a copy of the file in active presentation window.  

To open an existing presentation, perform the following steps: 

1. Select FileOpen menu option to display the Open dialog box:

• Click the Open File shortcut button  from standard toolbar, OR 

• Press the combination of Ctrl+O keys.
2. Select the location from the Look in drop-down list. For example, C:\New Folder
3. Select the file Mypresentation and click the Open button to open the file.
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Inserting Graphics and Spreadsheets 

A presentation that contains only text information can not be a good presentation. It is observed that a 
presentation without graphics can loose the audience interest on the topic. For example, the director of your 
company wants to know about the sales and production figures for the last four years. In this situation, one way 
is to present figures in text or numeric format, but it will take time to compare the performance figures for 
different periods. Another way is to depict the idea about sales and production through a comparison chart.  

You need to adjust the right emphasis on the appropriate graphic elements to support your message. Impress 
gives you the flexibility to create your own graphic elements using drawing tools. 

Inserting Lines and Shapes in Slides 

Impress enables you to create various graphics and flow charts in your presentation. For this purpose, it provides 
various AutoShapes that helps you to create these graphics. You can insert appropriate shape on your 
presentation by choosing a shape from the Drawing toolbar. To view the Drawing toolbar,   

Select ViewToolbarsDrawing menu option. The following figure shows the Drawing tool bar: 

Drawing Tool Bar 

To insert lines and shapes, click the line or the shape icon and point where you want to insert that line or shape. 
Press and hold the left mouse button down and hold it down while dragging to the opposite corner of that 
object. When you release the mouse button, the line or shape will be inserted on the slide. For example, to 
create a rectangle, click the rectangle icon on Drawing toolbar and point where you want to insert the 
rectangle. Press and hold the left mouse down while dragging to the opposite corner of the rectangle. When you 
release the mouse button, the rectangle will be inserted on the document. 

Inserting Text Box 

Text box is used to provide text information within a slide. For example, you have created a flow chart for the 
manufacture process of your company. You require text labels to define a particular process. When you add text 
to an object, it becomes an integral part of the object and moves along with it. You can add text entry to any 
shape using the drawing tools of Drawing toolbar.  

To add Textbox, perform the following steps: 

1. Click the Text icon  on the Drawing tool bar. 
2. Insert the text box on the selected slide.
3. Enter text, such as New York in the text box.

• If you resize a shape with the attached text, the size of the text does not change. So you have to
resize the text by selecting it and changing the font size.

Modifying Drawn Object 

Modifying the drawn objects on the slides allows you to make changes in the objects when required. If you want 
to modify any object, you have to select that object first. You can select one or more objects from your slides, 
as per your requirement. 

Here are some object selection methods: 

• To select one drawn object, click the object.
• To select more than one object, press the Shift key while clicking.
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• To select all objects on a slide, click EditSelect All.
• To deselect, press ESC key, or click anywhere on the blank area of the slide.

To resize an object, perform the following steps: 
1. Select the object and drag a sizing handle towards the center of the object to reduce its size.
2. Drag a sizing handle away from the centre of the object to enlarge its size.
To move an object, perform the following step: 

1. Select the object exactly on its edge, and while holding down the mouse button, drag it to the new desired
location.
• If you hold down Shift key while dragging, the objects can only be positioned on places that are

compatible with the page margins and the other objects on the page.

To copy an object, perform the following steps: 

1. Select object, and then right-click the object to display context menu.
2. Select Copy, and then again select Paste from context menu.
3. Drag the newly inserted copy of the object at an appropriate location.

Inserting 3D Shapes in Presentation 

The ability to draw 2D objects on your slides is useful, but now you may also be able to use 3D objects on your 
slides to make your presentation more impressive and interesting. Impress provides 3D Object toolbar which 
includes Cube, Sphere, Cylinder, Cone, Pyramid, Shell, and Half–Sphere. 

To use 3D shapes in your slides, perform the following steps: 

1. Select ViewToolbar3D Object, to display the 3D Object toolbar. The following figure shows how to use
3D-Objects:

2. Select the desired 3D shape from the toolbar, and drag it to the desired place in the slide.
• To rotate a 3D object around any of its three axes, select the object and then double-click on the

object to display its rotation handle. Drag the handle in the desired direction.

Changing Slide Order 

A good presentation displays the information in a predefined systematic order. Impress provides the facility to 
change the order of slides in a presentation. To change the slides order, you can use Slide-Sorter facility of 
Impress. It provides a way to view each slide in the order in which it will appear in your presentation.  

To change the order of slides, perform the following steps: 

1. Click the Slide Sorter tab to open the Slide Sorter tab page:
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• You can also select ViewSlide Sorter to open the Slide Sorter.
2. Select one or more slides, and then drag the slides to another location as per the requirement.
3. Hold down the SHIFT key and select the slides one by one
4. To create a copy of a selected slide, hold down CTRL key while you drag the slide. The mouse pointer

changes to a plus sign.
5. You can also drag a copy of a slide into another OpenOffice.org Impress document.

Adding Slide Transition   

Slide transition is the visual movement when viewing a presentation.  Impress provides many different transition 
effects:  

To apply a transition effect to a slide, perform the following steps: 

1. In Normal view, select the slide on which you want to add the transition effect.
2. Select Slide ShowSlide Transition to display the Slides Transition list on the right-side of the window.
3. Select a desired slide transition from the list, such as Wipe left, which moves the slide from right to left.

• You can preview the transition effect in the document window.

To apply the same transition effect to more than one slide, perform the following steps: 

1. In Slide Sorter view, select the slides to which you want to add the transition effects.
2. Select Slide ShowSlide Transition to display the Slide Transition list.
3. Select a slide transition from the list, such as Wipe Right, and click the Slide Show button to view the

slides.
• You can preview the transition effect for a slide by clicking the small arrow underneath the slide on the

Slides Pane.

To remove a transition effect, perform the following steps: 

1. In Slide Sorter View, select the slides that you want to remove from transition effects.
2. Select No Transition from the Slide Transition list.

Applying Object Transition 

You have created a presentation with number of bulleted items and pictures. When you move from one slide to 
the next, all the information in a slide is shown on the screen. You can use object transition effect to display one 
bulleted item at a time. This enables you to stay with one bulleted text for some time and then view the other 
bulleted time. 

Object transition helps you to focus on some important points like, control the flow of information, or simply add 
some Flash objects. To embed animation effect to an object, perform the following 
steps:  

1. Open a new Impress presentation.
2. Click the Normal view tab to open the Normal view tab page.
3. Select an object, such as rectangle from the Drawing toolbar that you want to

animate on a slide.
4. Select Slide ShowCustom Animation to display the Custom Animation dialog

box:
5. Click the Add… button to display the Custom Animation page:
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6. Select a desired animation effect, such as Fly in Slow, from the Basic list.
7. Click the OK button to view the rectangle flying in slow motion.

• If you want to preview the animation, click Play button  in the Task pane. 
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7. INTRODUCTION TO SPREADSHEETS
About Spreadsheet 

Have you seen your parents keep track of family expenditure? How do they do it? Have you noticed how they 
write the expenses, calculate the total, categorise similar types of items, prioritize expenses and also track the 
changes in expenses from month to month. A spreadsheet is an electronic document, very much like the way 
your parents maintain an expense sheet in a diary. 

The term spreadsheet was derived from a large piece of paper that accountants used for business finances. The 
accountant would spread information like costs, payments, taxes, income etc., out on a single, big, oversized 
sheet of paper to get a complete financial overview. 

Applications 

A spreadsheet consists of a grid made from columns and rows like a paper ledger sheet, however the biggest 
advantage is that when you make any changes, you do make manual calculations! The computer does it for you! 
Hence, spreadsheet provides much more flexibility, speed and accuracy, as compared to a manual expense 
sheet. It also has many features and functions built into it making it easy to use. Spreadsheets are used for a 
variety of tasks, such as  

• Maintaining records.
• Displaying data in a tabular form and as a graphical representation.
• Analysing data.
• Creating MIS (Management Information System) reports.
• Generating graphs (for pictorial representation of data).
• Making financial calculations.
• Managing inventory.
• Budgeting etc.

Some of the most popular spreadsheet software are: 

• MS-Excel
• Open Office – Calc
• Google Documents

Getting started with Spreadsheet 

To start you can choose any of the above software to start creating a Spreadsheet. You may start learning to use 
Spreadsheet with either the Openoffice – Calc or Microsoft-Excel. In this book, you will learn how to perform 
each action in both Openoffice – Calc and Microsoft-Excel. Make sure that the software is already installed in 
your computer. You can start using MS-Excel software, by performing any one of the following steps: 

1. Double click on a shortcut key of the MS-Excel icon, if available, on the desktop
OR 

2. Click Start > All Programs >Microsoft office>Microsoft Office Excel.

If you are using any other spreadsheet software, the steps to start it would be almost identical to what is given 
above, for example, if you were using Calc, you would click Start> Programs> OpenOffice.org (version)> 
OpenOffice Calc. 
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Once you start the MS-Excel, the following screen would be displayed. The components of the screen displayed 
are shown in the figure below. 

When an OpenOffice-Calc spreadsheet is opened, it looks like the figure shown below. Notice that the look 
and feel of MS-Excel and OpenOffice-Calc spreadsheet is quite similar. Also observe differences in the icons 
on the Ribbons. Most of the spreadsheet software have similar functions and features, with minor 
differences in the way, the tabs, icons, dialogue boxes and functions are arranged. If you learn to use one, 
it is fairly easy to use any other similar software. 

Ribbon 

Sheet Tab Horizontal Scroll Bar 

Vertical 
Scroll Bar 

View 
Buttons 

Cell Address Formula Bar Active Cell Column N 

Row 15 
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Some of the key components of a spreadsheet are: 

• Worksheet: This is a grid of horizontal rows and vertical columns.

• Workbook: A workbook contains one or more worksheets. has three worksheets (MS Excel by default
creates three worksheets), named Sheet1, Sheet2 and Sheet3. The Sheet Tab is pointing to Sheet2. The
current sheet shown in Figure 1 is Sheet1.

• Ribbon/ Toolbars: This consists of tabs groups and command buttons. . In Ms Excel a Ribbon has self
explanatory Tabs for a specific task. Groups within a tab are for the subtasks each tab performs. The
Command button (Icons) in each group either execute a command or display a menu of commands. The
Calc toolbars are explained a little later.

Ribbon MS-Excel 

Toolbars in OpenOffice Calc 

• Row: A row is a horizontal arrangement of cells. Each row has a row header identified by numbers (1, 2,
3, 4,…). In Figure 1the arrow points to Row 15.

• Columns: A column is a vertical arrangement of cells. Each column has a column header are identified by
alphabets (A, B, C, ….., Y, Z, AA, AB, AC, …., AZ, BA, ….). In Figure 1 the arrow points to Column N.

• Cell: A Cell is where the rows and columns intersect. Worksheet is also called an array of cells. A cell
may contain text, number, date or a formula. A cell is the fundamental element of a worksheet. This is
where numbers/text are entered. A cell address in a spreadsheet identifies location of the cell. It is a
combination of column name and row number of the cell, such as A2 or B16 etc.
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Note: When identifying a cell by its address, the column name is always listed first followed by row 
number.  

• Active Cell: This is the cell on which the cursor is currently placed. It is outlined by a dark border. Data
is always entered in the active cell. In Error! Reference source not found., the Active Cell is H7.

• Name Box: This displays the name of the active cell.

• Formula Bar: This is located below the Ribbon next to the Name box. It displays the contents of the
active cell. It can also be used to enter and edit data and formulas.

 Formula bar – MSExcel 

 Formula bar Calc 

Between the Name bar and the Formula bar are the icons  indicating Cancel,  indicating Enter 

and  indicating Insert function.  

• Scroll Bar: These helps to scroll through the content and body of the worksheet. There are two scroll
bars – horizontal and vertical.

• Quick Access Toolbar: This is an Ms Excel feature. It contains shortcuts for commonly used commands
such as Save, Undo, Redo etc.

Data Types 

Spreadsheets enable us to work with different kinds of data for organizing, calculating and presenting 
information. We will start by entering data in a spreadsheet. 

Open a new spreadsheet and enter the data as shown in the figure below. 

Observe three different kinds of data you have entered in the above spreadsheet. These are: 

• Text: The names of the students are treated as Text type of data. All labels are text entries.

• Number: The roll numbers are treated as Number type of data. Number sigs may have a currency sign($),
a percentage sign (%) or a decimal (.) sign in it.

• Date: The date of birth is treated as Date type of data (notice the entry in the formula bar when a cell
with a date entry is active).
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There is another kind of data which you can enter, which is called Formula. This is an equation that calculates 
the value that you want to display. You will learn about this a little later.  

You can also observe that text data is automatically aligned to the left in a cell, the Number data is aligned to 
right and the Date data is also right aligned. 

Note: You can do calculations using a Number, Date and Formula type of data, but you cannot do calculations 
using Text data (also referred as alpha numeric data). 

Toolbars 

While MS excel you have tabs>groups>command buttons, in Calc, you have toolbars. 

The Menu toolbar displays the main menus of Calc.  

The Standard or Function toolbar has icons for general functions such as Open, Save, Copy, Cut, Paste etc. 
When you place your mouse cursor over any of the elements of a toolbar, the name of the element appears on 
your screen. 

The formatting toolbar has icons for tools meant for calculation and cell formatting (number format, text 
alignment, borders etc).  

The Calculation toolbar (also called the formula bar) is meant for the entry of formula needed for calculations, 
and also shows active cell within the spreadsheet. 
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8. STARTING WITH SPREADSHEETS
Open - Enter data – Save - Close 

Let us start with understanding how to create a spreadsheet and save it for later use.To begin with, let us create 
a simple spreadsheet. Before creating the spreadsheet, create a folder “D:\IT Class IX\WP_Practice” where you 
shall store all the spreadsheets that you create. 

a) Open:

Start the spreadsheet as learnt in the previous chapter. When you create a spreadsheet, a default name is
given by the software. MS-Excel names it Book1, whereas OpenOffice names it as Untitled1.

a. When a new spreadsheet is opened, the sheet tab
usually has three worksheets – Sheet1, Sheet2 and
Sheet3.

b) Entering Data.

a. To go to cell B2, move cursor to the cell and then
left click the mouse. Cell B2 is now the active cell.
Now type the word Hello World and press Enter
key. You would notice that after pressing Enter,
automatically cell B3 becomes the active cell.

b. You can move to cell B4 by using down arrow key
of keyboard and type 423 and press enter.

c. Similarly enter 15-Aug-1947 in cell B6.

c) Saving a workbook
Save this workbook and give it the name First. To do so, the steps are the same as the ones you used for
saving a document file in a MS-Word. To quickly review the steps again:
o If using MS Excel, do the following:

 In the Quick Access bar, click the symbol for the floppy .
OR 
1. Click the File>Save. A Save As dialog box appears.

2. Choose the Directory (Drive and Folder) by clicking on the one that you want in the list
shown on the left hand side. You will see the path on the D:\IT Class IX\WP_Practice
displayed as you select the path.

3. Enter the name which you would like to
give to this document in the File name
box. For example, you can give the name
First to this file.

4. Click Save.

o If using Calc either click on the  symbol in the
standard tool bar or use the File menu. The frequently
used options of the menu are explained below:

o New: Used to create a new workbook.
o Open: Used to open an existing workbook.
o Close: Used to close the current workbook.
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o Save As: Used to save a new file for the first time or save an existing file with a different name.
o Save: Used to save a file you have edited/ made changes to. You can also use the shortcut keys

Ctrl+S to save a file as you continue to work in it.
The method for saving in Calc is same as in Excel. Try it out!

a. This workbook will be saved in MS-Excel with the name First.xlsx. The first part is the name given to
this file and .xlsx is the extension name for any worksheet created under MS-Excel.

b. Similarly if you are using OpenOffice, the file will get saved with the name First.ods. OpenOffice
gives an extension name of .ods to a spreadsheet file.

d) Close: Now you can close this spreadsheet by following one of the sets of commands given below:
a. Click the window’s control button marked “X”, on the top right hand corner of the screen.
OR 
b. Click File >Close.

e) Re-Open: Now re-open the above spreadsheet; make some more changes to it. Write the names of your class
mates in rows B7 to B12, and save it with a different name.

f) Save: Having made further changes, you need to save the changes. You can save it with the same name
First.xlsx, in which case the older file saved earlier will get overwritten by the changes which you made.
Alternatively, you may like to keep the earlier file First.xlsx as it is, and save this modified spreadsheet
using a new file name, e.g. Second.xlsx. To save it with the same name, just follow the steps explained
earlier. To save it with a different name, use the following steps:

a. Click the File>Save As.
b. A Save As dialog box appears. Choose the Directory (Drive and Folder) by clicking on the one that

you want in the list shown on the left hand side. You will see the path on the D:\IT Class
IX\WP_Practice displayed as you select the path.

c. Enter the file name which you would like to give to this document. For example, you may give the
name Second to this file.

d. Click the Save button.

Now this spreadsheet will be saved with the name Second.xlsx (or Second.ods in Calc depending on software 
used).  

Note: Click on the tab Sheet2. You would see that a blank worksheet appears on the screen. If you click again on 
tab for Sheet1, the data you had entered earlier would appear. Why? This is because these are separate sheets in 
the same workbook; just like pages on your notebook. 
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9. BASIC FEATURES OF A SPREADSHEET
What are cells columns rows and ranges? 

A cell is the intersection of a column and a row. To work with a cell, it has to be made active. The active cell 
has a dark border; selected cells have a light shading called a see-through selection. 

A range is a group of selected cells that you can edit, delete, format, print, or use in a formula just like a single 
cell. A range can be contiguous (all selected cells are next to each other) or non-contiguous (selected cells are 
not all adjacent).  

Selecting cells columns rows and ranges? 

Cell: To select a cell click on it. 

Row/ column: To select a column or a row, click on the column or row header button of the column or row you 
want to select. To select multiple contiguous columns or a rows drag the mouse over the column/row headers. 
To select multiple non-contiguous columns or a rows press the <Ctrl> key and click on the desired column/row 
headers. 

Range: To select a range, click on the first cell you want to include in the range and then drag the mouse 
pointer (keeping the mouse button pressed) to the last cell you want to include in the range. The first cell is the 
active cell and the others are all highlighted. 

To select a non-contiguous cells/range, select the first cell or the first range and then press the <Ctrl> key and 
select the rest of the cells/ranges. 

As you select a range, you can see the range reference in the Name box. A range reference shows the upper-left 
cell address, a colon (:), and the lower-right cell address, for example D10:F10. Non-contiguous cells are 
separated by commas, for example, A1:A7, C1:C27.  

You can click any cell in a selected range to deselect the entire range. 

Note: Which ever type of software you might use, the method of selecting cells, columns, rows and ranges is the 
same. 

Editing worksheets 

When you open a new workbook, it has three worksheets as shown in the figure below. The default names given 
to them is; Sheet1, Sheet2, and Sheet3. Each of these worksheets can have data entered in them. When you save 
the workbook in a file, the complete workbook with all the sheets in it get saved. You can edit worksheets by 
renaming sheets, adding or deleting sheets, moving a worksheet within a workbook or copying a worksheet. You 
can right click on the sheet tab to execute each o these operations. 

Sheet1 is 
displayed
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• If you click on Sheet2 tab, it is displayed.

 Right click popup menu – Excel   Right click popup menu Calc 

Renaming a worksheet 

You can change the name of the worksheet, to give it a meaningful 
name. For example it makes more sense if the name of Sheet2 is changed 
to Attendance, and name of Sheet3 is changed to Marks. 

o In Excel, if you double click on the Sheet tab, or select the
rename option from the popup menu, the sheet name becomes 
dark. Now you can type in the new name. (Note: Use 
single click for making the sheet active and double 
click for renaming).  

o In Calc, use the Rename Sheet option of the popup. A
Rename sheet dialog box appears allowing you to 
change the name. Click OK. 

Add a worksheet 

To add more worksheets in a workbook, 

o In Excel, click the symbol, as shown in the figure
adjacent. It adds one sheet. Each time you click it,
one sheet gets added. Alternatively, you can select
the sheet tab to the right of where you want to
insert the new sheet and from the popup menu
select Insert… →Worksheet.

o In Calc select the Insert Sheet option from the
popup menu, and an Insert sheet dialog box
appears (figure adjacent wherein you can specify
the position of the sheet, number of sheets and
even the name of the sheet.
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Remove a worksheet 

You can delete (remove) any worksheet from a workbook. In both Excel and Calc, select the Delete option from 
the popup menu. If it is a blank sheet, it is instantly deleted, but, if it contains data, a confirmation dialog box 
appears to reconfirm if you want to delete the sheet. 

In the workbook, Sheet1 has been deleted by following these steps. (figure adjacent). 

Moving/Copying a worksheet: 

Now that you have renamed, added and removed a worksheet, try the move/copy option in the popup menu. 
The figures below Move/copy dialog box for each software. Do you notice the similarity? 

Excel Calc 

Editing data  

The method for editing is the same for any software you use. 

When you open a workbook, the status bar shows the status as Ready . 

When you click on a blank cell and start entering data, the status bar shows the status as Enter . 
Double click on the cell you want to edit. Now, when you change the contents of a cell, i.e. edit it, the status 

bar changes to Edit . The cell contents are visible in the Formula bar. Use the mouse pointer or 
arrow keys to position on the insertion/deletion point in the cell. To delete characters use the Backspace or 
Delete keys. To insert, enter the characters. To accept the edit, either press Enter on the keyboard or click on 
the Enter icon on the Formula bar. 

To simultaneously enter the same data in the same position in multiple sheets, do the following: 

1. Depending on your need, either
• Hold down the Ctrl key, click on the respective sheet names and then release the key.

OR
• Select the Select All Sheets option from the popup menu.

2. The selected tab names have a white background. The name of the currently selected sheet will be in
bold. In cell F10 enter “Test 1” and press ENTER. The text “Test 1” will appear on all selected sheets on
cell F10. To stop adding data into the Sheets, hold down the Ctrl key then click on the Sheet tab of each
of the selected sheets.
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Copying data 

Note: 

In Excel, you will be using either the icons in the Home tab for cut/paste/copy or the right-click popup menu.  
In Calc, you will use either the icons on the standard toolbar or the Cut/paste/ Copy options in the Edit menu. 
Apart from this difference, the method is the same! Do you notice a similarity in the icons? 

Excel – Home tab & Rich-click menu Calc – Standard Toolbar icons & Edit menu 

o Create the data given above in a spreadsheet and click on cell E3. Enter: +C3-D3<Enter>.
o Click on the icon for Copy.
o Click on cell E5 and click on the icon for Paste.
o The formula is automatically pasted in the cell E5. You can also observe in the Formula Bar that the

address of the cells referred to in the formula automatically changes when Copy – Paste function is
used.
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Now copy the formula in other cells for 
calculating savings for April, May and June. 

There is an alternate and easier way to paste 
formula: Copy – Click and Drag – Paste.  

The Copy-Paste method can become very time 
consuming, if the same formula has to be pasted 
in a large number of cells, say one hundred 
cells. Spreadsheet has a faster way of pasting 
the formula that you have copied. 

In the same worksheet add six more records for 
the months July to December. Enter data for 
Income and Expense as in the adjacent figure. 
Do the following: 

o Take cursor to cell E8. Copy formula, as
you did earlier. You will see that the 
box around cell E8 starts blinking. Observe that the blinking box in cell E8 has a small dark rectangle in 
the bottom right hand corner. 

o Position the cursor over this rectangle. This spot is also called the Fill Handle. The cursor will take the
shape of +. Click the left button of your mouse and drag the cursor with your mouse keeping the left 
button pressed. Drag the cursor up to cell E14 and then release the left button. You will see that the 
formula has been automatically pasted to the entire range specified. 

Note: If you copy-paste into cells that already contain data, you may lose original data as it will be overwritten 
by the new copied data. 

Moving data 

Moving contents from one cell to another is sometimes necessary especially when you are making changes in a 
spreadsheet. You can move data using the Cut-Paste method. Using this method, you can move data across cells 
in the same worksheet, across worksheets or even across workbooks. To try this method, you will move data 
from cell A1 to cell D1. Do the following: 

1. Enter your name in the cell A1, and ensure that this is the active cell.

2. Click on the Cut icon . You will notice that cell A1 now has a blinking border.
3. Click on the destination cell D1 and click on the Paste icon. Your name has moved from A1 to D1. A1

is now empty.

Another method of moving is to Drag and Drop. In this method, do the following: 

1. Highlight and select the cells(s) that you want to move.
2. Click and hold anywhere in the selected range and drag it to the new position.
3. Release the mouse button to move the data to the new position.

Note: The shortcut key for Cut is Ctrl+X, for Copy is Ctrl+C, and, for Paste is Ctrl+V. 
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Inserting and deleting cells columns and rows 

Create a spreadsheet with the data given above. 

Using a spreadsheet, you can modify a worksheet or report created earlier. While working a on a spreadsheet you 
may realize that you need to insert some information between two columns. Now do you re-create the sheet all 
over again? Now you will learn the solution to such a problem. You will now add a column which has the Unit 
Value of each item, after column C. 

a) Inserting a Column: You will add a column which has the Unit Value of each item, after column C in the
figure below.
o Position the cursor near the Column D, (as shown in the figure above) the cursor

changes into an arrow shape. Select the column. 
o In Excel, do the following:

• Right-click the mouse. Select the Insert option from the popup menu.
(adjacent figure ).

o In Calc, do the following:

• Select the option Column from the main menu item Insert.
o A blank column is inserted in this place. There is a ripple movement of data, i.e.

the contents of Column D move rightwards into Column E and so on. This is called 
inserting a column.  

You can now enter data in this column and update the worksheet. 

Note: The cell addresses in formulas (if any ) will change automatically. 

b) Inserting a Row: Similarly a row can be inserted in a spreadsheet. Position the cursor on the Row header,
where you want to insert a row. The whole row gets highlighted.

In Excel you right click and insert a row whereas in Calc you would do either of the following

1. Use the Rows option of the Insert menu

OR 

1. Right click on the selected cells and select the Insert Cells option.

2. The Insert Cells dialog box appears. Choose the Entire Row radio button and click on OK button.
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Calc - Insert Menu - Right-click Popup Insert Cells dialog box 

Note: 

• If you select multiple rows, before selecting the Insert options, both Excel and Calc insert the same
number of new rows as you had selected.

• There is a ripple movement of data, i.e. the original contents of rows move downwards and cell
addresses in formula change accordingly.

To practice, add one more item in this spreadsheet by adding a row at row number 8. The spreadsheet will now 
look like the figure below. Practice by inserting more rows and columns in the spreadsheet. 

c) Deleting Row(s)/Column(s): You have learnt to insert a row and a column in an existing spreadsheet. In a
similar way, you can delete any row of column in a spreadsheet.

In Excel, do the following: 
o Select the row or the column to be deleted. Right click the mouse. A short cut menu appears.

o Choose the option Delete. The selected row or column will be deleted.
The options of this popup are explained below: 

o Select Delete Cells… Used to delete selected cell(s).

o Select Delete Sheet Rows is used to delete selected
row(s).
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o Select Delete Sheet Columns is used to delete selected column(s).

o Alternatively, on the Home tab, in the Cells group, you can click on the arrow next to Delete. The same
popup appears. 

Similarly, in Calc, to delete do either of the following 

o Select the row/column header(s) to be deleted and right click on the selected header(s). Select the
option Delete Rows or Delete Columns from the popup menu. The row(s)/ column(s) disappear! 

Or 
o Select the row/column header(s) to be deleted and select

Edit> Delete Cells from the menu bar.T 

Note: When you delete rows/columns, the data contained in that 
row or column will also get deleted. 
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10. FORMATTING IN A SPREADSHEET
A spreadsheet provides many formatting tools to make your worksheets look more attractive and professional. 
Without formatting, a worksheet may look like meaningless data put together. To highlight important 
information, you can change the appearance of selected numbers and text, add currency signs, commas, and 
other numerical formats, or apply align the text or make it bold or italicised. 

Just as in a list that you create on paper or a report you may read, the information in a spreadsheet can be made 
more readable by formatting (bolding, shading, etc.) a cell and its contents.  

Note: 

Before we start, as in the previous chapters, you will learn the method of formatting in both Excel and Calc. 
Just as in Excel, we use the Font and Alignment groups of the Home tab or the right click popup menu, in Calc, 
we use the Format>Cells main menu options or right click on the selection and use the popup menu. 

Excel Icons used for formatting 

       Calc – Format menu list 

Open a new spreadsheet. Create the spreadsheet as given below. It shows a partial list of items in a stationary 
shop and the opening balance and closing balance for a month. 
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Unformatted Sample 
You will now format the data to make it look like the figure below. 

Formatted Sample 

Notice that the above sheet has some additional effects to format it. What are adjustments and settings which 
have been done in the formatted spreadsheet? These are: 

a) Wrap Text: The text in row number 1 does not completely fit in the cell, as the cell width is smaller than
the length of the text.
o Go to cell A1 and press the left button of

the mouse and drag the mouse till cell E1 
and release the left button. You will see 
that the cells A1 to E1 have been 
selected. 

Note: When a cell entry overlaps into adjacent cells and there is no entry there, the contents are 
visible. However, the moment and entry is made in the adjacent cell, the text gets truncated, i.e. It is 
there on the sheet but not visible. An alternate is to automatically make text appear on multiple lines 
in a cell. This means that you can format the cell so that the text wraps automatically using the Wrap 
Text function. 

o In Excel, click on Home tab, and then Wrap Text in the Alignment group.
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o In Calc, to wrap text within a cell,
right click the selected area and select
Format cells..., or select Format >
Cells from the main menu. The
Format Cells dialog box appears.

o Click on the Alignment tab.

o Check the Wrap text automatically
option. 

o Click OK. Now the contents of the cell
will be wrapped to fit the cell. 

Note: Select the Shrink to fit cell option in 
the Format Cells dialog box to 
automatically adjust the font size thus 
making the data fit in the cell. This is called shrinking text to fit in the cell. 

b) Change Font:

You have learnt to use Bold, italics and Underline in a word processor. The same functions are found in all 
spreadsheets too. The text in row A are in Bold. 

o Select the cell range A1 to E1.

Excel Calc 

o Now press the icon B. The contents of the selected cells will change to Bold font.

Similarly you can change the contents of any cell or a group of cells by selecting them and using the 
appropriate icon, B, I or U.  

c) Cell Content Alignment: The numbers in Cells A2 to A11 are right aligned in the unformatted sample
spreadsheet. However in the formatted sample, they are center aligned. To achieve this effect, do the
following:

o Go to cell A2. select cells A2 to A11.
o In Excel, under the Home tab, in the Alignment group, click the symbol for Center alignment.
o In Calc, click on the center alignment icon on the Formatting toolbar. Some more alignment options will

be available when you click on the down arrow at the end of the toolbar. 

Excel Calc Additional options - Calc 
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To align position of the contents of a cell, you need to select that cell or the group of cells and then click on the 
appropriate symbol for Left, Center or Right alignment of text. 

Formatting numbers 

When spreadsheets are used in accounting, we often need to show money and cash balances using currency 
symbols. Create the spreadsheet shown below. 

The price given in this sample spreadsheet does not indicate whether it is in Dollars or Rupees or in Euros. If you 
want to display numbers as amounts, you need to format the numbers as currency. To do this, apply the 
Currency format to the cells. A currency symbol can be inserted in two ways. These are: 

In Excel: 

1. Use the Accounting Number Format button

The currency formatting option is available within the 
Accounting Number Format button under the Home tab, in the 
Number group. 

o Select Cell E1.
o Click on the down arrow next to the Accounting

Number Format button (figure adjacent)
o A list appears showing some of the popular

currency symbols. Select Rs. Option. The amount
40 would be displayed as shown in the figure below. Repeat this procedure for other cells
in the column..

2. Use the right click

o Select the Cell in which currency symbol is to be applied
o Right click the mouse. A short cut menu appears.
o Click on the option Format Cells. A Format Cells dialogue box appears.
o Select Currency from the Category list provided.
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o Now click on the down arrow on the Symbol box .Available currency symbols are displayed.
Choose the desired symbol. This symbol will be displayed in the cell.

In Calc, do the following: 

You can either use the icons on the formatting toolbar  or the Numbers tab in the 
Format Cells dialog box. Using this tab, you can apply any of the data types in the Category list to the data or 
control the number of decimal places and leading zeros.  

d) Change Column Width/Row Height: (The method is the same in both Excel and Calc.) The text in column
number C in the unformatted sample does not fit into the width of the column. The width of the column C
can be increase to ensure that the entire text entered is visible.

o Take the cursor to the column numbers on top. Position it on the line between Column C and D, (refer

adjacent figure). The shape of the cursor changes to a symbol. 
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o Click the left button of the mouse and with the left

button pressed, drag the  symbol to the right. 
You will notice that the width of the column starts 
increasing. Once you have the desired width, 
release the left button of the mouse. 

Note: 

• Similarly, to change the row height, plavce the cursor between two rows, till the shape of the
cursor changes. Then drag to the desired width.

• To quickly change the row height/ column width for all rows/columns in the spreadsheet, double

click on the Select All button (the intersection between the columns and rows ). Now 
any changes you make to one column/row is applied to all columns / rows in the spreadsheet. 

Creating cell border 

e) Create a Border: The data in the formatted sample has Borders around each cell. To achieve this effect, do
the following:

o Select cells A1 to E11.

o In Excel, do the following:

 Click on down arrow next to the icon for borders in the Font group under the Home tab, as
shown by the arrow in the figure below. A list of types of borders appears.

 From this list select the option for All Borders. You will observe that each of selected cells get a
border.

OR 
 Right click on the selected cells and select the Format Cells option. A Format cells dialog box

appears.

 Click on the Border tab and you can specify the border style, color etc here.

76



 Right click Short cut menu Format Cells – Excel 

o In Calc, you can either use the border icon  on the formatting toolbar or, use the Borders tab of 
the Format Cells dialog box to define the border line arrangement, the shadow style, color etc. 

Coloring the cells (Fill Color) 

The method for Coloring cells is similar to that for bordering the cells. 

In Excel, you can either use the option of applying Color  under the Home tab, in the Font group, or, you 
can use the Fill tab of the Format Cells dialog box, to color the cells. 

In Calc too, you can either use the Color icon  on the formatting toolbar or use the Background tab of the 
Format Cells dialog box. 

Auto Formatting 

Here you will learn about the auto format feature of Calc. You can use the AutoFormat feature to quickly apply a 
set of cell formats to a sheet or a selected cell range. 
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1. Select the cells that you want to format, including the column and row headers.
2. Click Format > AutoFormat.

3. You can click on the More button to select the properties (number format, font, alignment, borders,
pattern, autofit width and height) to be included in the AutoFormat. You can select or deselect the
required options.

4. Click OK.

Print a worksheet 

The method for printing a worksheet is almost similar to the one you used for printing a document in a word 
processor. The best method is to preview the print output, adjust the print settings and then print the 
spreadsheet. By now, you have seen that the method in any software you use is more or less the same for each 
operation.  

Print Preview 

To preview your worksheet in Excel, do the following: 

1. Select File>Print>Print Preview.
2. Click on the Page Setup command button to make changes to the page. The Page setup dialog box

appears. Explore each tab and see the available options. Some common options are:

a. Margins: This option allows you to change the margin settings for Top, Bottom, Left and Right
Margins in the printed page.

b. Orientation: Using this option you can change the orientation of printing between Portrait and
Landscape. In portrait mode, the height of the paper is more than the width.

c. Size: This option allows you to change the size of the paper to be used for printing. Most of the
normal printing is done using either A4 or the Letter sized paper.

d. Print Area: This option is used, when you do not want to print the complete worksheet, but
want to print only a part of the worksheet. In this case:

3. To close the preview click on Close Preview.
4. Make adjustments to the print settings and preview once again.
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To preview your worksheet in Calc, do the following: 

1. Select File>Page Preview from the main menu or click the  icon on the Standard toolbar. 
2. The print preview appears. Use the navigation buttons to view the print area.
3. To close the preview click on Close Preview.
4. Make adjustments to the print settings and preview once again.
5. Click on the Format>Page on the main menu, to make changes to print settings.
6. Here you can select the type of paper format, height, width, orientation, margins etc.
7. To view the page breaks for large worksheets, click View> Page Break Preview on the main menu. You

can now see the page breaks highlighted on the spreadsheet. When you place your cursor on the page

break, its shape changes to . Drag the breaks to adjust your print area.
8. Click View > Normal on the menu bar. The worksheet returns to the normal view.

Print a worksheet - with default settings 

Open any of the workbooks created be you in the earlier exercises.(the method is same for any software.) 

1. Select File > Print.
2. If you have selected a specific range for printing, you need to select the radio button Selection.
3. The worksheet will be printed. Do make sure that you have a printer connected to your computer.

Note: To print just a selected portion, select the cells to be printed and then follow step 1. 
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